Download

Can't record UE4?

Hey guys. First of all, I’m almost positive this was the wrong place to post this, but I didn’t know where the correct place to post it was, so forgive me for that. I’ve found that I’m completely unable to record UE4, regardless of what program I use. I’ve tried using FRAPS, but it doesn’t pick up the window. I ran the game in a separate window and then recorded, but it only gave me sound and a black screen. I’ve tried BandiCam and Camtasia, but they both give me errors when trying to record UE4 - but not when I try to record anything else. Even if it’s not specifically UE4’s window that’s selected for recording. If UE4 is open while I’m trying to record, I get errors. Why is this?

FYI: I’m trying to record the engine itself, not just gameplay. Gameplay doesn’t work either, though.

Use a common desktop recorder instead of DirectX/OpenGL one like Fraps;
Each window in UE4 is a separete process I guess, so with those recorders you would record only a single panel at time when that panel has focus.

Also check video drivers…

As I said, it didn’t work with Camtasia or Bandicam either. It works on anything else though…

I’ve been able to record it with Dxtory, works best in standalone game mode. If you still having trouble then record packaged game instead of the editor.

Use OBS Multiplatform, it is how I record all my tutorials. Use a Display Capture source for when you want to record the engine. When you press play the game window will also be captured as long as it’s on the same monitor.

https://youtube.com/watch?v=Oex7PJM3pJk

yep, I’ve used OBS and camstudio to record the editor however I’ve also had random issues with both, for me NVidia’s Shadowplay works better then any other programs I have tried.

Ah. So, OBS isn’t working at all for me (I’ve used it before for streaming, but not recording). I set up all of the settings for recording and everything, yet I get a black screen. Made sure that I had the correct scene and source set up and everything, but to no avail. Luckily, I got Camtasia working. Apparently it didn’t have a codec selected, which is weird, because it did at first and I never changed anything. Thanks for the help!