Download

Can't package on GearVR with Samsung S7 Edge on 4.11.0

Here this is my configuration I am not a programmer so I have been just followed documentations or videotutorials so far ive got to this, if you see something odd please let me know:
screen1.jpg9620e2820a68522298afe153245fbc6520463a73.jpeg81a1c4361fb421103fcf1d4f2737468356100622.jpegscreen4.jpg

You don’t need to set NDK level to android-21, it works fine with android-19 (changing to 21 means you need source to compile the engine).

And the distribution checkbox is in Packaging project settings. It is probably off but I wanted to check.

Sorry I forgot about that one, I have tried setting all in android-19 but receibed the same error

screen5.jpg

Hi, Some more feed for this thread:

When trying to build any BP tempalte for Gear VR, I get this in my log: (building C++ 1st person template works but I’m more of an artist so would like to work with BP)

Cmd: OBJ SAVEPACKAGE PACKAGE="/Game/NewMap" FILE=“C:/Users/user/Documents/Unreal Projects/VR_GearVR_BP_001/Saved/Autosaves/Game/UEDPCNewMap.umap” SILENT=true AUTOSAVING=true KEEPDIRTY=true
LogSavePackage: Save=20.09ms
LogSavePackage: Moving ‘C:/Users/User/Documents/Unreal Projects/VR_GearVR_BP_001/Saved/UEDPCNewMapF900ACB647FAE52F0CD885867973871F.tmp’ to ‘C:/Users/User/Documents/Unreal Projects/VR_GearVR_BP_001/Saved/Autosaves/Game/UEDPCNewMap.umap’
LogSavePackage:Display: Finished SavePackage C:/Users/User/Documents/Unreal Projects/VR_GearVR_BP_001/Saved/Autosaves/Game/UEDPCNewMap.umap
LogEditorTransaction: Undo Spawn Play From Here Start
UATHelper: Packaging (Android (ETC2)): Running AutomationTool…
UATHelper: Packaging (Android (ETC2)): Automation.ParseCommandLine: Parsing command line: -ScriptsForProject=“C:/Users/User/Documents/Unreal Projects/VR_GearVR_BP_001/VR_GearVR_BP_001.uproject” BuildCookRun -nocompile -nocompileeditor -installed -nop4 -project=“C:/Users/User/Documen
UATHelper: Packaging (Android (ETC2)): ts/Unreal Projects/VR_GearVR_BP_001/VR_GearVR_BP_001.uproject” -cook -stage -archive -archivedirectory=“C:/Users/User/Documents/Unreal Projects/VR_GearVR_BP_001” -package -clientconfig=Development -ue4exe=UE4Editor-Cmd.exe -pak -prereqs -nodebuginfo -targetplatform=Android -cookflavor=ETC2 -build -CrashReporter -u
tf8output
UATHelper: Packaging (Android (ETC2)): Automation.Process: Setting up command environment.
UATHelper: Packaging (Android (ETC2)): BuildCookRun.SetupParams: Setting up ProjectParams for C:\Users\User\Documents\Unreal Projects\VR_GearVR_BP_001\VR_GearVR_BP_001.uproject
UATHelper: Packaging (Android (ETC2)): Project.Build: ********** BUILD COMMAND STARTED **********
UATHelper: Packaging (Android (ETC2)): CommandUtils.Run: Run: D:\Program Files\Epic Games\4.13\Engine\Binaries\DotNET\UnrealBuildTool.exe UE4Game Android Development -remoteini=“C:\Users\User\Documents\Unreal Projects\VR_GearVR_BP_001” -noxge -generatemanifest -NoHotReload
UATHelper: Packaging (Android (ETC2)): UnrealBuildTool: NDK version: 21, GccVersion: 4.9
UATHelper: Packaging (Android (ETC2)): UnrealBuildTool: building WITHOUT VULKAN define
UATHelper: Packaging (Android (ETC2)): UnrealBuildTool: Vulkan SDK is installed, but the project disabled Vulkan (bSupportsVulkan setting in Engine). Disabling Vulkan RHI for Android
UATHelper: Packaging (Android (ETC2)): UnrealBuildTool: ERROR: No modules found to build. All requested binaries were already part of the installed engine data.
UATHelper: Packaging (Android (ETC2)): CommandUtils.Run: Run: Took 0.7805005s to run UnrealBuildTool.exe, ExitCode=5
UATHelper: Packaging (Android (ETC2)): Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.CommandUtils+CommandFailedException: Command failed (Result:5): D:\Program Files\Epic Games\4.13\Engine\Binaries\DotNET\UnrealBuildTool.exe UE4Game Android Development -remoteini=“C:\Users\User\Documents\Unreal Projects\VR_GearVR_BP_00
1” -noxge -generatemanifest -NoHotReload. See logfile for details: ‘UnrealBuildTool-2016.09.20-01.39.39.txt’
UATHelper: Packaging (Android (ETC2)): at AutomationTool.CommandUtils.RunAndLog(String App, String CommandLine, Stri
UATHelper: Packaging (Android (ETC2)): ng Logfile, Int32 MaxSuccessCode, String Input, ERunOptions Options, Dictionary2 EnvVars, SpewFilterCallbackType SpewFilterCallback) UATHelper: Packaging (Android (ETC2)): at AutomationTool.CommandUtils.RunAndLog(CommandEnvironment Env, String App, String CommandLine, String LogName, Int32 MaxSuccessCode, String Input, ERunOptions Options, Dictionary2 EnvVars, SpewFilterCallbackType SpewFilterCallback)
UATHelper: Packaging (Android (ETC2)): at AutomationTool.CommandUtils.RunUBT(CommandEnvironment Env, String UBTExecutable, String CommandLine, String LogName, Dictionary2 EnvVars) UATHelper: Packaging (Android (ETC2)): at AutomationTool.CommandUtils.RunUBT(CommandEnvironment Env, String UBTExecutable, FileReference Project, String Target, String Platform, String Config, String AdditionalArgs, String LogName, Dictionary2 EnvVars)
UATHelper: Packaging (Android (ETC2)): at AutomationTool.UE4Build.BuildWithUBT(String TargetName, UnrealTargetPlatform TargetPlatform, String Config, FileReference UprojectPath, Boolean ForceMonolithic, Boolean ForceNonUnity, Boolean ForceDebugInfo, Boolean ForceFlushMac, Boolean DisableXGE, String InAddArgs, Boolean ForceUnity, Dictionary2 EnvVars) UATHelper: Packaging (Android (ETC2)): at AutomationTool.UE4Build.Build(BuildAgenda Agenda, Nullable1 InDeleteBuildProducts, Boolean InUpdateVersionFiles, Boolean InForceNoXGE, Boolean InUseParallelExecutor, Boolean InForceNonUnity, Boolean InForceUnity, Boolean InShowProgress, Dictionary2 PlatformEnvVars, Nullable1 InChangelistNumberOverride, Dictiona
ry2 InTargetToManifest) UATHelper: Packaging (Android (ETC2)): at Project.Build(BuildCommand Command, ProjectParams Params, Int32 WorkingCL, ProjectBuildTargets TargetMask) UATHelper: Packaging (Android (ETC2)): at BuildCookRun.DoBuildCookRun(ProjectParams Params) UATHelper: Packaging (Android (ETC2)): at AutomationTool.BuildCommand.Execute() UATHelper: Packaging (Android (ETC2)): at AutomationTool.Automation.Execute(List1 CommandsToExecute, CaselessDictionary1 Commands) UATHelper: Packaging (Android (ETC2)): at AutomationTool.Automation.Process(String] Arguments) UATHelper: Packaging (Android (ETC2)): at AutomationTool.Program.MainProc(Object Param) UATHelper: Packaging (Android (ETC2)): at AutomationTool.InternalUtils.RunSingleInstance(Func2 Main, Object Param)
UATHelper: Packaging (Android (ETC2)): at AutomationTool.Program.Main()
UATHelper: Packaging (Android (ETC2)): Program.Main: AutomationTool exiting with ExitCode=5 (5)
UATHelper: Packaging (Android (ETC2)): BUILD FAILED
PackagingResults:Error: Error Unknown Error

Are BP projects compatible with GearVR? I would assume they are…

@earvant:

I see two possibilities. I see “NDK version: 21” which would require recompiling if you were using armv7 instead of arm64 (we use 19 for binaries for armv7 and 21 for arm64). The other one is you have a plugin enabled that shouldn’t be.

@Chris, thanks for the reply.

I’ve started with testing on 19 for both SDK and NDK, same error. Only other plugin active is Substance, all other plugins are standard plugins and all non-oculus plugins have been disabled. Building a C++ works, building BP = error.

EDIT: Disabled Substance plugin and BP packaging seems to work now. Wasn’t expecting Substance plugin to be the problem. Is this a known issue and are there plans to fix this? Funny that C++ packaging works with Substance enabled and BP packaging doesn’t.