Can't package my project for Windows

As the title says, just like many others before, I too cannot package my project. Its been a week, and I’ve searched long enough, I cannot find a fix to this problem. All the forums, all the videos, you either just install visual studio 2013/2015 or the sdk or the common tools, or delete some unnecessary folders, and “problem solved” . Most of the questions are regarding android, but Im packaging the project for Windows!
I had to make a post and show my error message.

I hope that someone can help me out, without being able to package a project whats the use anyway. Its very important that it packages correctly.

i have the same problem right now :confused:

I think i found a fix, not tested yet but if you open the setup for the version of visual studio that ue4 is using and click on modify you should be able to find an option ti install c++ stuff. This is probably the thing missing :slight_smile:

After a minute or 2 of packaging it gives this error :confused: for windows 32 and 64 packaging

Program.Main: ERROR: AutomationTool terminated with exception: System.IO.InvalidDataException: Found invalid data while decoding. at GroupIconResource.ReadIconHeader(BinaryReader Reader)
at GroupIconResource.FromIco(String FileName)
at BaseWinPlatform.StageBootstrapExecutable(DeploymentContext SC, String ExeName, String TargetFile, String StagedRelativeTargetPath, String StagedArguments)
at BaseWinPlatform.GetFilesToDeployOrStage(ProjectParams Params, DeploymentContext SC)
at Win32Platform.GetFilesToDeployOrStage(ProjectParams Params, DeploymentContext SC)
at Project.CreateStagingManifest(ProjectParams Params, DeploymentContext SC)
at Project.CopyBuildToStagingDirectory(ProjectParams Params)
at BuildCookRun.DoBuildCookRun(ProjectParams Params) at BuildCookRun.ExecuteBuild()
at AutomationTool.BuildCommand.Execute() at AutomationTool.Automation.Execute(List1 CommandsToExecute, CaselessDictionary1 Commands)
at AutomationTool.Automation.Process(String[] Arguments)
at AutomationTool.Program.MainProc(Object Param)
at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param)
at AutomationTool.Program.Main() UATHelper: Packaging (Windows (32-bit)): Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown)

This last error was because of my project, the icon in the project settngs for windows was a png file renamed to .ico, after converting it using a website into .ico file it fixed it and now i can compile the project :slight_smile:

it seems to have fixed it

will need to wait for it to finish packaging and i will give my results!

Thank you for helping out, I’ll try that when I get my hands on the project again.

Have you got it to work?