Can't package my app for IOS because it thinks my project is code based?

I have a windows and my app is PURE BPs. I have no code and don’t even have Visual studio installed anyways. However when I try to package my app it gives me this error, “packaging a code-based project for the selected platform is currently not supported. This feature may be available in a future release.?” Anyone know how to fix this nonsense. Thanks you!

More than likely you have enabled a non-standard plugin, so it wants to re-link the executable to include it. If you haven’t enabled plugin, go to your project directory and delete the intermediate directory. Re-run the editor and try the package again.

-Pete

sorry that didn’t work. Every time I try to remove the intermediate directory and open my project the intermediate directory automatically pops up again. Also I don’t have much plugins enabled these are the only ones I have enabled are paper 2D, BP stats, Epic survey, messenger Debugger and Plugin browser that’s it. Any clues why this is happening?

Hello Spookey0188,

Could you provide the logs from when you attempt to package? Having context on the error message could provide some more information on why it may be seeing your project as a code project. Something else that may be helpful, could you also package for Windows once and post the log for that as well? This could include more information on why it is compiling code.

Also, please avoid bumping your post until at least 48 hours have passed without a response, unless you have more information to provide.

Hey. When i package my app not only do i get the “packaging a code-based project for the selected platform is currently not supported.”, But I also get these 2 errors.

83015-error.png

I thought that I need to follow those two errors and get a key and join the apple Dev program.

However, I created a new project and packaged that new project for IOS and of course i got the same two errors however, I didn’t get the “packaging a code-based project for the selected platform is currently not supported” AND also it opened up the file explorer telling me where would I want to package the app even though I didn’t have a key or anything. What’s wrong with my project?

please fallow the documents to fix your problem. you 1st need to setup an Dev account for ios and android. this issue you are having is you have not setup your provision profile or your signing key. but to get those you need to fallow the docs bellow. hope this helps you.

for IOS.

then do this.

https://docs.unrealengine.com/latest/INT/Platforms/iOS/QuickStart/3/index.html

For Android.

go to.

search on answers how to set up android.

Ok very well then, but how come it’s giving me a “your project contains code” error and doesn’t open the file explorer when the other new project didn’t give me that error and resumes to open for explorer even though both projects didn’t have the key signing and the other stuff??? I just want to fix the “packaging a code-based project for the selected platform is currently not supported” error.

Look at what plugins are enabled for the project that does work and compare that to your project which doesn’t work. If you have enabled any new ones or disabled any of the common ones, then we will need to re-link the executable and so that would explain why it thinks it is code.

-Pete

Ya unfortunately I have that plugin already disabled, but still get an error. These are the plugins I have enabled paper 2D, BP stats, Epic survey, messenger Debugger and Plugin browser.

i have had that problem before. turn out i had substance designer plugin still enabled. ones you disable it you wont get the “packaging a code-based project” error.

try to disable Plugin browser and BP stats i just checked my projects and i don’t have those 2 enabled.

Awesome thanks that did the trick! I just had to disable BP stats!

im glade i could help and that the problem is fixed.

If anyone still having problems even after comparing plugins with a valid project like me, a very simple solution is to edit directly the .uproject file and remove the plugins part.

Example, i changed from this :

{
	"FileVersion": 3,
	"EngineAssociation": "4.11",
	"Category": "",
	"Description": "",
	"Plugins": [
		{
			"Name": "WindowsDeviceProfileSelector",
			"Enabled": true
		},
		{
			"Name": "ArchVisCharacter",
			"Enabled": false
		},
		{
			"Name": "PluginBrowser",
			"Enabled": true
		}
	],
	"TargetPlatforms": [
		"Android",
		"IOS"
	]
}

to this

{
	"FileVersion": 3,
	"EngineAssociation": "4.11",
	"Category": "",
	"Description": ""
}