Can't package game on one specific computer

Hi everyone, I have an issue with packaging, but only on one computer.

We have two identical computers, connected on the same network. One packages just fine, mine does not.

We’re using perforce so it is the exact same code.

The error I get when packaging is this: UATHelper: Packaging (Windows (64-bit)): ERROR: System.IO.IOException: The process cannot access the file ‘S:\UE4\Project\Saved\StagedBuilds\WindowsNoEditor\Project.exe’ because it is being used by another process.

If I understand this correctly it seems like some process is locking the .exe and therefore the packaging cant continue.

Things I have tried to resolve this:

  • Cleaned project folders (Intermediate, Saved) and plugin folders
  • I have tried packaging to different locations on the computer
  • Turned off VPN
  • Turned off network completely
  • Restarted computer
  • Launched from visual studio
  • Turned off all firewalls
  • Created empty new project
  • Packaged from console/automation tool without having UE4 running

Nothing seems to be working, however, I have been able to package a few times, just out of luck it seems like. I cant find any consistency in when I am able to package.

I have looked into the “is being used by another process” issue and it seems to be more related to Windows rather than UE4, so not sure what to make of this.

Any help would be appreciated!

Same here, I’m lost… Thankfully if you take the “WindowsNoEditor” folder from “StagedBuilds” everything works.

Whoooaa thanks so much GodOfPampers! I’ve been bashing my head for the past week, searching with the wrong terms and now I can finally export

I am having similar issues in 4.27. I thought I had solved it but it came back later - seems kinda random to me as well as sometimes it works and some times doesn’t, even if I don’t change anything.

@GodOfPampers method works for my error. Try deleting “WindowsNoEditor” from “StagedBuilds” then package again.

Hello guys! I’m having the same error when i try to package my game for another PC. Did anybody find a way to remove this error? THANKS!!!