Can't package game for android

I try to package a simple 3rd person project but fail with error: “You are missing some required components for Android game creation”.

Here’s my setup:

  1. I installed UE 4.5.0 from Launcher
  2. I installed Android SDK to G:/android/sdk and set ANDROID_HOME to that path
  3. I installed Android NDK to G:/android/ndk and set NDKROOT to that path
  4. I installed the latest JDK to G:/java/jdk and set JAVA_HOME to that path
  5. I installed Apache Ant to G:/ant and set ANT_HOME to that path
  6. I created a project based on Third Person BP template
  7. I try to package a project but get an error

What should I do else? I guess maybe I need some additional packages installed in my Android SDK. The packages I already have installed are:

  • Android SDK Tools 23
  • Android SDK Platform-tools 21
  • Android SDK Build Tools 20
  • API 10 and API 20 platforms
  • Android Support Library 21
  • Google Play Services 20
  • Google Play Libraries
  • Google USB Driver 11

What else?

Howdy TimGS,

Thank you for reporting this issue. Would you be able to attach your DXdiag and your project log files to this post? Also, what version of UE4 are you currently using to package your project?

Any additional information would be greatly appreciated.

Thanks and have a great day!

Here’s DxDiag and Log
Project log

I use 4.5.0 version. But when I try 4.4 I get an error, too. Maybe, something is wrong with my Android SDK setup. I just can’t figure out what.

I also can’t see my device in Launch - devices, but it’s present in Device Manager.

Did you happen to follow this tutorial: Setting Up Unreal Engine Projects for Android Development | Unreal Engine Documentation ?

No, I used this one Android Development Basics for Unreal Engine | Unreal Engine Documentation

I succeeded wth that once but then I had to change my workstation and reinstalled everything and now I fail to package android app.

It would be great to have an option to see what exactly I’m missing because now the error is too vague to debug the issue

Have you attempted to uninstall and then reinstall the SDK? it is a possibility that something in the SDK failed to build correctly and may just have to be reinstalled.

Here is a link that may be helpful with what you are currently seeing: Android Packaging For Distribution Failed - Mobile - Unreal Engine Forums

It seems that SDK 20 is causing issues because we have not upgraded to it yet.

So, TADP 3.0 won’t work, too?

Yes, I tried that but still no luck.

It is still in experimental stages so it may not work. I would highly recommend what the fix that Josh Adams has linked in that post to fix the issue. There are also a couple of photos from users that may help you with your issue.

For what it’s worth, I am downloading API 21 SDK and NDK right now, to see what I can get working in UE4 :slight_smile:

I confirm that TADP 3.0r4 failed to package on 4.5.1. Back to TADP 2.0r8 (API19 with SDK r22.3) fixes the issue.

Strange. TADP 3.0r3 works for me.

Hey, Josh. I tried to install TADP 3.0 and it works! Strange, because it sets the same env variables as I did manually before. I guess that pure SDK doesn’t work, only Eclipse bundle does. But I don’t think I will experiment because everything works now.