Can't package error X3004: undeclared identifier 'GetIndirectOcclusion'

I’m trying to package my game on 4.13 but whenever I do it fails and I get this error. It says something about worldgridmaterial but I’m not sure why that would cause any problems.

[UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.09.11-02.34.21:223][  0]LogShaderCompilers:Warning: 1 Shader compiler errors compiling WorldGridMaterial for platform PCD3D_SM4:
UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.09.11-02.34.21:223][  0]LogShaderCompilers:Warning: Engine/Shaders/BasePassPixelShader.usf(1004,24-78): Shader TBasePassPSFCachedPointIndirectLightingPolicy, VF FVectorFieldVisualizationVertexFactory:
UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd:     error X3004: undeclared identifier 'GetIndirectOcclusion'
UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: 
UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.09.11-02.34.21:223][  0]LogShaderCompilers:Warning:  BasePassPixelShader.usf(1004,24-78):  error X3004: undeclared identifier 'GetIndirectOcclusion'
UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.09.11-02.34.22:257][  0]LogWindows:Error: begin: stack for UAT
UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.09.11-02.34.22:258][  0]LogWindows:Error: === Critical error: ===][1]

HI ZomboJoe,

Can you please provide more context for your build and project with the information I’ll need below?

  • When you package your project have you changed any settings in the Project Settings for the targeted platforms (Android, Windows, iOS), and/or using any specific target from the File > Package > menu?
  • Are you targeting a SM4 platform specifically and disabling SM5?
  • Have you made changes to your WorldGridMaterial by opening it in the Material editor?
  • If you create a new blank project and try to package with only the default settings, do you get the same error message?




I made a blank project and moved everything from my content browser in it. It seems to work well now. Thanks.

I’m having the issue locally too. Interesting that two people have the same issue on 4.13. Was your project converted from an earlier version? Are you doing anything in VR? Trying to find the similarities.

Ok, solved it on my end. Seems to come from having Instanced Stereo Rendering enabled but under Platform-> Windows not having Shader Model 4 unchecked (ISR is SM5 only).

Thanks for that, I had the same issue and that solved it for me.

Hey Tim,

I ran into the exact same issue. I am using a source built engine version (4.13) and targeting sm5 and sm4. I did not change the world grid material and i don’t get the error in a blank project. Any clue what can cause this?

This issue is related to the forwad renderer. If the forward rendering is enabled it requires SM5 only and won’t cook for SM4. So you have to uncheck sm4.