Can't package/deploy fresh template project for Android


Unchecked support arm64.

Under Project Settings>Platform>Android, I clicked on the Red Tabs for APK packaging and Play Services to load platform files, and each turned green.

After that I tried to package it via File>PackageProject>Android>Multi(…)
Got me [ error log][2].

100896-log1.txt (360 KB)
[2]: 100897-log_1.txt (423 KB)


Please do not change any of your settings once you’ve provided me with the following:

  • What is your Platforms > Android > Minimum SDK set to?
  • What does your SDK look like? (screenshot, please)

Thank you! :slight_smile:

Hello ,
Thank you very much for the response.

・What is your Platforms > Android > Minimum SDK set to?

・What does your SDK look like? (screenshot, please)

Try changing the [PROJECT] to something simple in the package name (eg: package name might be com.test.sample)

Also, have you tried compiling to a different location? Maybe try compiling to C:\Compiles

Add in the bottom slot, like I have here:


Hello ,
Thank you again for the prompt response.

I take it the Android SDK settings apply to all projects (by default)?
That is, in the test project I set:

  • “SDK API Level” to “matchndk”
  • “NDK API Level” to “android-19”

Then attempted to package the test/template project and it worked.
I then tried to launch the template/test project to Android and it worked.

So basically, unchecking “Support arm64” in Android menu > Build section, in addition to setting the SDK/NDK API Levels as you specified made it all work.

On a side, after that I went back to the original project I was having trouble packaging/building android on, and found that those settings had automatically been changed to:

  • “SDK API Level” to “matchndk”
  • “NDK API Level” to “android-19”

just like in the sample project, though originally it had been set to “latest” and “” (nothing).

Anyway, trying to build the original project with arm64 disabled and SDK/NDK API Levels set to “matchndk” and “android-19” respectively, it’s still failing.

Regardless, I can now package/deploy a fresh template to Android. So that means thread is resolved.

I guess I’ll open up a new thread for the original project I’d been having problems with.

Thank you!

, thanks a lot for the help!

's instructions allowed the test/template to package/launch on android. Those instructions fixed the issue I had with it. Unfortunately it didn’t fix the issue on my original project which is a bit more complex (or lived in) than the default template.

After having made sure Support arm64 was unchecked and SDK/NDK API levels were set as S. described, I tried to package it and it failed like :

LogPlayLevel: Program.Main: AutomationTool exiting with ExitCode=5 (5)
LogPlayLevel: Domain_ProcessExit
LogPlayLevel: copying UAT log files…
LogPlayLevel: Completed Launch On Stage: Build Task, Time: 20.253061
PackagingResults:Error: エラー Launch failed! Unknown Error

I then tried to do what you specified:
I changed the project package name from the default com.MyCompany.[PROJECT] or whatever to “com.test.sample”.

Having done that it fails with the same error.

“Also, have you tried compiling to a different location?”
I don’t think I’ve tried . Where exactly do you change the compile location?
If it’s the folder you are requested to select after going to File>PackageProject>Android>Android(Multi:ETC1) then yes, I just now tried it.
Created a new folder on C: called “Compiles” and it failed with the same error.

A while ago, I copied the project folder so I could work on it at home. The next day when I brought it back to work I was worried it might be worse than the project at work, so before copying it over I changed the name of the project folder just so it didn’t overwrite anything in the original. Turned out the modified version was OK so I kept working with it.

I wonder if that has anything to do with all of .

Anyway, thanks for your help , much appreciated!

I’m glad you’ve been able to package in general for Android. Have you ever been able to package for your project though? If so, what version of the engine were you on? Have you already shared project with me in the past, I know I’ve helped you quite a few times.


“I’m glad you’ve been able to package in general for Android.”

Me too. Much thanks to you. So I guess means that codeworks is properly set up, and the problem lies somewhere in specific problematic project.

“Have you ever been able to package for your project though? If so, what version of the engine were you on?”

Yes I have. That was before I added that DoN Navigation plugin for pathfinding. If memory serves me correct, it was on 4.12.4 that I had it running launching to Android. Note, that at that time I copied the project folder so I could work on it at home. When I brought the modified project back to work, I changed the folder name (so the work version served as a backup). I do vaguely recall that at some point even though the name of the project folder was different in Explorer, the Epic launcher didn’t reflect it.

I’ve since deleted the backup and am continuing to work on the project version that had been copied and pasted a couple times.

Last time you checked out that project, I made changes only to the gameplay logic. I made no changes to the (Android, Android SDK) project settings whatsoever. Just a guess, but I’m thinking there’s some lingering, deprecated dependencies on my machine that were caused by me renaming the project folder.

Should I open up one more thread?

Try disabling any additional plugins you’ve added into your project and see if that’s the cause, since you said it started happening after adding DoN Navigation plugin.

If it turns out not to be a plugin issue, open a new thread.

Thank you! :slight_smile:

I tried again today and I was able to package/launch the game for Android (Multi:ETC1). The only thing different time was the PC had been turned on and off after having set SDK/NDK API Levels to “matchndk” and “android-19” respectively. Thank you very much for your time, .

You’re very welcome. I’m glad has been resolved.

Please let us know if you have any further questions! :slight_smile: