Can't Package and cook the game version 4.11.2

Hi,
I can’t package the game for deploy, I attached the log file .
It seems to be a Critical error:
Fatal error: [File:D:\BuildFarm\buildmachine_++UE4+Release-4.11\Engine\Source\Runtime\Launch\Private\Windows\LaunchWindows.cpp] [Line: 83]
SECURE CRT: Invalid parameter detected.
Expression: Unknown Function: Unknown. File: Unknown Line: 0

I am really disappointed I worked so hard and just can’t publish the project, how can I do this from visual studio or at least to where can I search to remove te problem recompile the engine etc a work around something.

link text

I’m having a similar issue. Game packages in 4.11.1 and all previous builds, now I can’t get anything to compile on Android since the hotfix

Just last night, It seems I resolved the problem creating a blank code file and also deleted intermediate and saved folder from game project, then everything worked normal.

didn’t work for me. I’m working on a blueprint project. Good thought, but deleting the saved and intermediate folder didn’t resolve the problem for me

I am having exact same error message, but I cant fix mine no matter what I do. Also I have tried with a blank project :frowning:

This must be a issue on 4.11.2 as a few others posted the same error message.

It seems the problem persists, today I created a new project and had the same problem, but once again did the steps above and it’s solved. It is obvious there is a problem on project compiler.

Unfortunately I have the same issue but deleting the saved & intermediate doesn’t seem to solve it. I might try and create a blank C++ file for a temp fix but is there any specific way you are doing this? Through the editor or through VS?

I deleted the saved and intermediate from windows explorer, bu first I made the c++ file then recompiled the project from VS. But for next project it does not work, it seems there is still something happening.

Hello everyone, I apologize for the delay but I would like to attempt to get to the bottom of the issue. Is anyone still experiencing these problems? If so, does Ion’s fix below at least temporarily work for you? Also, just in case there have been any changes or in the event that there may be different errors occurring here, can each of you that are having this issue post your own logs from when it fails?

In your projects, are they blueprint only projects or do they also have code in them? Have you experienced this issue with any other projects? Was the project that this is occurring in converted from a previous version of the engine such as 4.10? As much information as you can give would be helpful.

Hi Matthew, It is ok just let’s try to solve this. The problem is still there, on last project I used only blueprints, and also Substance Materials from PBR substance pack. Files in dropbox the upload from forum seems to have problems, it says file is to small or no file.
Here is the output log and the log from cook:

Also if you don’t see from logs I can upload full project maybe that way will be easyer for you.

Hi Matthew, thanks for getting on this. My issue seemed to magically resolve itself after about a week. One day it wasn’t working, next day it was. I was having problems stated on this thread - Can't launch and build for Android - Mobile - Unreal Engine Forums

That would be helpful. It would let me see the project settings you’re using and also allow me to see if the issue will reproduce on my machine. If you would need to keep it private for any reason you can feel free to provide the download link via a private message on our forums.

Hi guys, it seem the problem is solved after it got in my mind to disable some plugins, So I disabled all that are beta alpha and also others that I don’t need for example android my app is windows only. And it seems that resolved the problem for this project and also for other projects I have. Don’t know yet maybe Mathew will find something more about this, but you can try to do my way until then :), maybe it will work for you to.

Thanks for this answer, I didn’t get a chance to work on getting my own project to build until today and tried this fix out. I have two plugins installed but I’m not using either much so I just disabled them both.

Builds now work perfectly!

The two plugins I turned off were Substance and Modo if anyone needs to know.

Substance has no problem, I work a lot with it, and the projects were with substance enabled.

What plugin is it that is causing problems? Does the issue go away if the plugin is temporarily disabled? Did you use this plugin in this project prior to 4.11.2 and if so, did you get a newer version of the plugin to go along with the engine upgrade? I’m still in the process of trying to gather more information.

We are experiencing the same type of data cook failure related to a different plugin. Full clean builds do not resolve the issue for is.

InstaLOD plugin. I’m in communication with the plugin developer as we try to diagnose/debug it. Yes, the problem only occurs when the plugin is enabled.

The plugin itself is build from source code (so goes along with 4.11.2) and uses a pre-build DLL file. The error only occurs in the Windows data cook - the Mac data cook succeeded.

Here is the command line used:

Engine/Build/BatchFiles/RunUAT.bat BuildCookRun -server -project=G:\windows-slave-1\game-build-windows\build\UnrealEngine4\GameProject\Descent.uproject -noP4 -platform=Win64 -serverplatform=Win64 -clientconfig=Shipping -serverconfig=Shipping -cook -allmaps -stage -pak -archive -archivedirectory=G:\windows-slave-1\game-build-windows\output -utf8output -buildmachine

Here is the output log snippet of the failure:

I have been able to build a project that fails during cook.
This bug is actually unrelated to InstaLOD or its mesh reduction, and I guess this bug is the reason other plugins seem to crash during cook at random:

As soon as a module invokes printf or cout it crashes, no matter what type of string is sent to the standard io. It just crashes, even if it is the first line of code that is executed inside the module. And I am pretty sure this is the reason why other plugins like the substance plugin crashes for some users and not for others, because stdio output might vary based on what substance is being processed.

This is also the reason why it doesn’t crash on mac or linux, because only on windows the secure crt exists. There must be a bug within UE4 that only happens when running UE4 from the commandline.
UE4 is probably only using the secure CRT in certain cases, like when building for shipping via terminal and unfortunately the CRT is not setup correctly.

You can get more infos about InstaLOD at www.instaLOD.io . InstaLOD is a 3D optimization plugin and provides features to automatically optimize 3D models, generate LOD, perform draw call reductions and more.