Can't Open Launcher - Error 0xc000007b

I downloaded and installed the Epic Games Launcher today, using “EpicGamesLauncherInstaller-2.2.0-2568893.msi” (from the main page). However, I can’t start the launcher, since I get an error (0xc000007b). I tried reinstalling the launcher, not using the default directory, as well as reinstalling / repair MVC++2012.
Using the Tracker none of the listed Errors appeared in my Log and I can’t seem to find the error. Any idea what I could try next?

Log file: Log.txt


Uhm, just to clarify: Of course I meant “Can’t open Launcher”. Sorry for that.

Hi Khurshid,

It looks like you tried a few things already but could you make sure to go through all of the suggestions in this section of the troubleshooting guide?

If nothing works, follow the instructions towards the bottom of that link to generate your Debug Logs. Post them here, along with your Dxdiag (System Specs).

I did update my graphics driver, but sadly that didn’t change anything.
Creating the Dxdiag worked fine, generating the Debug Logs however did not. I can’t find the created files, since there is no folder ‘EpicGamesLauncher’ under AppData\Local. Maybe that error will help.
Here my Dxdiag file:dxdiag.txt

You are probably not getting any launcher logs because it is failing to load one of the required dependencies long before the launcher even has a chance to initialize. The answer in this thread describes how to use a tool called Dependency Walker to generate a log that should help you pinpoint the problem. Unreal Engine won't launch Error code (0xc000007b) - Installation & Setup - Unreal Engine Forums

If you get stuck, we’ll be happy to take a look at the log.

I had included the Walker Logs in my first post. However, I did create a new one, seeing as I tried some new things. I did not find any of the errors given in bold, but when searching for “launcher” I found that the ‘aqprof.dll’ returned NULL (line 5670). After that I tried a ‘sfc /scannow’, which told me that there are some corrupted files. In the ‘CBS.log’ I couldn’t fine anything (no idea what to look for and it’s quite big). I’ll just include the Walker log as well as the CBS.

Walker: log.txt
CBS: CBS.log

According to your Dependency Walker logs, it appears that you have an x86 version of the following DLL:

Entry from logs:

[*E ]  c:\windows\system32\VSPERF120.DLL  ...   x86  

The windows\system32 folder should have an x64 version of that dll. Once you get that DLL repaired you should be good to go. The problem now: That DLL does not seem to be part of the VS redist so I’m not sure exactly why the launcher is referencing it or how to repair it. Do you have Visual Studio installed?

According to my Control Panel I have “MVS 2010 Tools for Office Runtime (x64)”, “MVS Express 2013 for Windows - ENU” and “MSV Professional 2013”. Just updated / repaired all of those as well.

Try this:

  1. Find and backup your current C:\Windows\System32\VSPERF120.dll. You can do this by renaming it to VSPERF120.dll_BACKUP
  2. (Optional) Test to see if the launcher now runs.
  3. Run the repair option on Visual Stuido 2013.
  4. Check to make sure you have a new VSPERF120.dll.
  5. Run the launcher.

Sorry for the late answere, I kinda lost hope of being able to fix it.
Sadly, repairing did not help, even though I do have a newly created VSPerf120.dll.
Is it possible that I have the wrong version of Visual Studio 2013?

The 0xc000007b error code can be displayed for a few reasons, it may be that another component is failing now that you fixed up Vsperf120.dll. Perhaps you could post up another Dependency walker log and I’ll have a look.

Ok, I just created a new log, also checked for those common errors
( [E], [ ! ] and/or [!6] ) but didn’t find anything.

Log: Log.txt

It looks like you fixed the VSPerf120.dll issue you were having before but there still seem to be some issues in the new log. Here are the log lines that look suspicious.

  • GetProcAddress(0x00007FFECD0D0000 [KERNEL32.DLL], “GetFileInformationByHandleExW”) called from “VSPERF120.DLL” at address 0x00007FFEB76A866C and returned NULL. Error: The specified procedure could not be found (127).
  • GetProcAddress(0x00007FFECD0D0000 [KERNEL32.DLL], “SetFileInformationByHandleW”) called from “VSPERF120.DLL” at address 0x00007FFEB76A868A and returned NULL. Error: The specified procedure could not be found (127).
  • LoadLibraryW(“VtuneApi.dll”) returned NULL. Error: The specified module could not be found (126).
  • LoadLibraryW(“VtuneApi32e.dll”) returned NULL. Error: The specified module could not be found (126).

My log is filled with missing module errors, do you know how I would fix this? :frowning:


In order for us to best support you, we have recently modified our process for how we handle Launcher issues.

Please visit:

Here you will find information and solutions for common issues, as well as a contact form if you still need additional assistance.



The first thing that jumps out is an issue with XINPUT1_3.DLL. The fix you can try would look something like this:

  1. Backup this file c:\windows\system32\XINPUT1_3.DLL by renaming it to XINPUT1_3.DLL_BACKUP

  2. Run the DirectX setup from here: Download DirectX End-User Runtimes (June 2010) from Official Microsoft Download Center

  3. Ensure a new version of this file was put here: c:\windows\system32\XINPUT1_3.DLL

If that does not work, we have recently modified the process for how Epic Games can help troubleshoot your Launcher issue. Please visit for technical support, here you can find information and solutions for common issues, as well as a contact form if you still need additional assistance. To access the contact form, please use the “Email Us” button under the “Contact Us” section.

This actually worked perfectly for me! Thank you 0xDEADBEEF! :slight_smile: