Download

Can't open files after installing Animation&Rigging Toolkit

This is strange, and I can’t find anyone else referencing this issue. (This is in Maya 2014)

I’ve installed the Animation&Rigging Toolkit successfully. I have complete access to the menus and tools. I’ve also used it to create fully operational rigs, published and ready for animating.

After I installed the ART tools, there are two Problems:
If I double click on absolutely any .mb file, the file opens, I see the proper scene with all elements correctly for a split second.
THEN… the scene immediately blanks out, and becomes a completely empty scene. It is as if I just opened a blank scene in Maya. Nothing in the viewport, or the outliner etc… totally empty.

I can however open a new scene in Maya, and then drag my .mb file into the viewport and the file opens correctly. Or, I can go to file>import .mb and the file opens correctly.

This problem is immediately resolved once I remove the usersetup.py file from my Maya scripts folder.

The other problem is after I finish rigging up a character in ART and publish it. I try to re-open the rig reference file, but I cannot save any changes. I try to publish the new rig changes, but it simply doesn’t save the changes. I try to actually File>Save to overwrite the rig reference file, and it literally doesn’t overwrite the new file.

There is a problem with the file references, so the directory must be totally messed up somehow. But I have checked and double checked. I am mystified.

Does this make sense to anyone at all?

To specify…

The character is not editable once published.
I try to edit existing published character by selecting “edit character” from the Epic Games drop down menu. The rig file opens and there is no references, I cannot return to a rig pose or a model pose, nor can I publish any changes made. I can click “build control rig”, and then I press “build”, but the button will not execute any action.

After messing around I have a better understanding of the ART tools process.
I can save alterations to my control curves and rig in individual animation files as long as I keep them in the right directory (animation folder).

Still doesn’t explain why .mb files are blank when I open them, but by removing the userSetup.py from my Maya user directory that problem is solved so… *Shrugs

Hello,
sorry I have the same exact problem as you, if I open any Maya file, I see the scene for a second and then they disappear.
Can you tell me how you managed to solve it?
Thanks.