Can't open console on 4.9

I can’t open the console on 4.9 no matter what. I’ve tried changing the input key to some alternatives but it still doesn’t work in the editor neither a standalone game… 4.8 works fine on the same machine. (Windows 10).

Any ideas?

Same problem here,
I guess we have to wait until tuesday when unreal devs are back again.

ew… just notice it too right now… hitting console key nothing happens.

Go to Edit->Editor Preferences->Keyboard shorcuts then search “console”

Change the assigned key, In my case i selected Shift+~ and now it works!

They changed the console dialog, now appears in the bottom-center as small edit window.

1 Like

It worked indeed! Thanks!
That’s odd… Default tilde key without the “Shift +” should work… Looks like a bug maybe…

For the console to open in-game I had to remap the console-key under Settings->Project-Settings->Input->Console.
As there is no easy way to reach ~ on the German keyboard we always use ^. Strangely there are to keys listed, the second one works for me. The first one adds “ConsoleKeys=Caret” to the DefaultInput.ini, the second one adds “ConsoleKeys=^”

In my case, the problem was when my keyboard language was not in English (I use both canadian french and english and switch with alt-left shift).

I didn’t verify but I believe that this behavior changed from 4.8 to 4.9.

RESOLVED for UE 4.10
Answer at 4:22

if anyone still got problems: PRESS SHIFT + F1 for mouse input.
Only then i was able to pass the command (whatever key it is mapped for) for opening the console to the editor test game.

Suggested fix does not work for me

I fixed the issue, i had my English key board as English US INTERNATIONAL, i changed it to English US only and it worked.