Download

Can't Open C++ when trying to start new project, but can open blueprint just fine

Imgur

Any help? I am embarrassed and mildly frustrated that I can’t figure this out.

You can check this similar issue with the same rename error, for them it turns out the anti virus was denying the renaming permission.
Topic here

I tried the solution for them and it didn’t work.

also I can’t compile nor write in C++. I can open blueprints, but not c++. That’s when I get that error message.

It might be that something is preventing the compiler from renaming the mentioned file or it doesn’t have permission in that folder. I would try moving the project folder somewhere else like the desktop and make sure no program is interfering with file permissions or trying to manipulate that file.

I tried running as admin and got this message:

Could you try this:

tried it and got this messoge:

Have you tried compiling the project from Visual Studio?

Dumb question coming right now in your direction. How do I do that?

When there isn’t anything to compile as I can’t write any code.

There is something to compile. Your error is caused at compile time. Just because you didn’t write the code doesn’t mean there’s not anything to compile.

Open the solution (.sln) file in your project folder and press compile / build. Think the shortcut in Visual Studio is Ctrl + Shift + B or Shift + B or something.

will try

says there were build errors and would you like to recompile them and then says would you like to recompile them manually?

Says this:

Build started…
1>------ Skipped Build: Project: UE4, Configuration: BuiltWithUnrealBuildTool Win32 ------
1>Project not selected to build for this solution configuration
2>------ Build started: Project: MyProject4, Configuration: Development_Editor x64 ------
2>Building MyProject4Editor…
2>Using Visual Studio 2019 14.29.30133 toolchain (C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC\Tools\MSVC\14.29.30133) and Windows 10.0.18362.0 SDK (C:\Program Files (x86)\Windows Kits\10).
2>Building 8 actions with 12 processes…
2> [1/8] SharedPCH.Engine.ShadowErrors.cpp
2>EXEC : error : Unable to rename C:\Users\Daniel\Desktop\Unreal Projects\MyProject4\Intermediate\Build\Win64\MyProject4Editor\Development\Engine\SharedPCH.Engine.ShadowErrors.h.txt.tmp to C:\Users\Daniel\Desktop\Unreal Projects\MyProject4\Intermediate\Build\Win64\MyProject4Editor\Development\Engine\SharedPCH.Engine.ShadowErrors.h.txt
2>C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Microsoft\VC\v160\Microsoft.MakeFile.Targets(45,5): error MSB3073: The command “C:\Users\Daniel\Desktop\unreal\UE_4.27\Engine\Build\BatchFiles\Build.bat MyProject4Editor Win64 Development -Project=“C:\Users\Daniel\Desktop\Unreal Projects\MyProject4\MyProject4.uproject” -WaitMutex -FromMsBuild” exited with code 6.
2>Done building project “MyProject4.vcxproj” – FAILED.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 1 skipped ==========

Close Visual Studio and Unreal Engine.

Open “Visual Studio Installer”. If your Visual Studio has an update, update it.

When updated, click modify. Make sure you have “Game Development with C++” installed.

It looks like your compiler doesn’t know what a header file is.

It’s up to date

Do you have “Game development with C++” installed too? It’s further down the list and mentions Unreal Engine specifically.

Yes, sorry for the long wait to respond. Unreal community forbid me to comment due to being a newb. I have also made the move to unity because unreal is acting up and I can’t figure out why. Such a shame.

You running incredibuild by chance ??if you are Uninstall your license for it that way you have it if need it again and than Uninstall incredibuild and than a restart should work thats the only time I have seen that problem