Can't name a project on Mac OS X

On Mac OS X (10.10.2), the new project function inside the Epic Games Launcher will not let me type in the Project Name field. Clicking the text area seems to accept focus for half of a second before changing focus to the Starter Content drop-down element.

It lets me create a project, but each project is successively named MyProject#.

Edit: I just updated the Launcher to 2.0.1 and the engine to 4.7.2. I was wrong in my initial post. The part that isn’t letting me change the name is the Unreal Project Browser that loads after you click Launch in the engine. Even after updating, it’s still not allowing me to change the text in the box.

This is a brand new, almost completely stock 5k Retina iMac with 32GB of Memory. I just bought it last week and haven’t had time to clutter it up with a bunch of crazy stuff yet, so it basically just has Skype, Chrome, Sublime Text 2, Adobe Flash CS6, and Unreal installed.

Specifically this section down at the bottom:

Attempting to place a mouse cursor in the Name field always fails and it feels like it’s selecting the With Starter Content box right above it. If I move quickly, I can sometimes click in the box and type in a character or two, but that’s fairly rare.

Your workaround of cloning the project with a new name does work, so I’m going to do that. Just wanted to let you guys know that this is happening to me.

This is with Epic Games Launcher v 2.0.0.

Hi tehblister,

I am unable to reproduce your issue on Launcher v2.0.1. Also, I have not heard any other reports of this kind from other Mac users which leads me to believe it may be related to your device, although not 100% of course. So to troubleshoot, have you tried downloading the latest launcher? Can you lightly double tap the “Name” field so the contents stay highlighted blue -without trying to enter any text? You can start with these steps.

In the meantime, as a workaround until this is resolved, you could create a new project named “MyProject#” as a base. Locate the project in the Library tab, rmb and chose clone: The pop-up window will allow you to rename the clone.

Try the troubleshooting steps and let me know if this is still a problem.


I updated everything and tried again, still no luck. I provided some additional info and screenshots in the original post. Thanks for looking into this for me. Your work-around with the cloning does work, so I’ll do that for now.

I have entered a bug report: JIRA [UE-11320]. If the developers are able to identify and correct this issue, an update will be added to this post.

Thank you for your feedback.

Yep. Thanks again for your help.

Are you by chance using multiple monitors?
If so could you try swapping which side the primary one is on?
(make sure the secondary monitor is to the right of the primary, in desktop space. I’m not sure how you do that on a mac. Windows it’s in the “Screen Resolution” settings.)

Nope, just the 27-inch 5k iMac display.

Thanks, that rules out that possibility.

I am also having this same issue. Though I can usually fix by restarting my but after a few moments of working I am no longer able to use these fields if I want to say change the Translation or scale of the object.

Hi NotserpD,

Please Post this as a new question since the bug entered for this post may not be related to your issue.


I have this exact same problem, also with a new Retina iMac, maxed out everything. This is with launcher 2.12.14, UE 4.13.2, macOS 10.12.1. I tried cloning, but got a warning saying that it is not supported for code projects, and code changes might be necessary. Is cloning still the only way to deal with this? Would any code changes be necessary for a brand new project?

I have the same problem of not being able to name new projects on my new 27" 5k iMac. I also had problems with a completely different game launcher not working, and that was blamed on the dual graphics cards configuration that comes with maxed out iMacs these days, so I don’t know if that could be the case here as well. I’m doing code projects for the class I am taking, so I am not sure how well the clone work around will function since doing so generates a warning about possibly needing to change code. Any info you could give me would be greatly appreciated. Thank you.

Since we cannot reproduce this on our end we cannot address the issue. In addition to making sure you are running the latest drivers for your GPU, I suggest making a new Blueprint project and cloning that. Then you can add C++ elements after the fact. The only reason it would be an issue is because the cloned version would have different directory paths from the original.

I had the same problem (+ others interface problems in the editor).

I solve this by unplugging my xbox360 gamepad, which had one of the joystick pushed at one direction.

So, maybe it can be a controller plug in your computer which interfers with UE4.

Hope it can help someone and sorry for my broken english :),

This issue was resolved here: macOS, Unreal editor won't select bottom row of buttons - UI - Epic Developer Community Forums
but obviously this bug report never got updated. In my case it was a Logitech G13 game pad that was interfering with the editor, and unplugging it did the trick. So bottom line, if you’re using a Mac and having any weird problems with selecting interface items in the editor, try getting rid of all input peripherals except a basic mouse.

I’ve dealt with this myself and the only way I can fix it is if I drag the window a bit first and only then is when it’ll allow me to change the Project Name and select templates. (Same OS/UE4 versions).

Hope that helps!

had the same problem and realise that my Joystick for XPlane where pushed out, i’ve unplug it and everything goes right :slight_smile:

So if the problem still running check connected device and unplug them…

I had a steering wheel attached, causing the same problem using the latest Unreal (4.18.3) / Epic launcher. After the steering wheel was unplugged, everything works fine.
Seems to be a UI focus issue to me, wondering if it has the same behaviour in a game built by unreal?

i can not create project name on unreal
how to fix it[link text][1]