Can't move character since 4.11 update

Using version 4.10 I’ve created a simple FPS project (without using sample code), and it all worked pretty neatly. Then, when 4.11 rolled out, I thought I’d update my project. But since then, my character won’t move (expect for looking around with mouse) - even gravity won’t affect it.

void APlayerCharacter::MoveX(float Val)
	if ((Controller != NULL) && (Val != 0.0f))
		GEngine->AddOnScreenDebugMessage(-1, 2.f, FColor::Red, "X Axis value: " + FString::SanitizeFloat(Val)); //Shows values of X axis correcty, so it's not problem with input
		AddMovementInput(GetActorForwardVector(), Val);

Also, I’ve double-checked if Auto-Activate is marked in CharacterMovement component.
Tried creating new project and reuse the code, but the result was the same.

Any ideas about what could be wrong?

Same problem here.

My problem was that in my overridden BeginPlay() method, I was not calling Super::BeginPlay(). Adding this call, the character re-started to consume movement inputs.

It actually worked!
Now I’m a bit embarrased I didn’t think about tinkering with BeginPlay().
Thanks :slight_smile:

haha, I’m embarassed, too. Also ran into this problem but should’ve known better. I missed a lot of super calls in my classes I noticed :smiley:

Thank you so much Kafu! This had me too and I would have never thought of looking for BeginPlay, You’ve saved me a lot of time, thank you :slight_smile: