Cant make purchases from the Marketplace

I’m having a problem where i am unable to purchase any content from the marketplace i just revive an error message saying that something when wrong. I’ve tried this from both Unreal 4 marketplace and from here on the website. I’ve tried logging in and out but nothing has worked. I’ve included the error messages I receive.

Hello there! I’m sorry to hear you’re having issues with your purchase. Can you contact us at with the email address you use to log in to the launcher? We’ll take a look at your account, find the issue, and see what we can do to help.

I am having the exact same issue going on more than 3 days. The only difference is I don’t even get as far as the original poster.

I sent the email as described in the answer by clicking on the ‘Need Help?’ link. I responded to an informational request sent via email to me by Epic staff yesterday, and still haven’t heard back. Is there any kind of ETA on when I can expect to hear back on this issue?

Same issue, I’ll reach out to contact provided. But I feel if more than a few people are having the issue it could be bigger.

I am having the same issue as well. After making a purchase successfully, my 2nd purchase (no matter what I try to purchase) fails with the same “Something Went Wrong!” message. Attempting to purchase online gives the same “Sorry, to order the preview failed…” message. Is there any solution to this issue yet?

Hi all! We’re looking into this right now and will update here when it’s resolved. If you haven’t yet contacted with the email address you used to log in, please do so that we can better track this issue. Thank you for your patience.

Hi everyone! We’ve made the fix and everything should now be working as intended. If it isn’t, please contact us at and we’ll look into it further. We apologize for the inconvenience, and once again, thank you for your patience.