Download

Can't make an APK without SDK API 'android-28' minimum installed

hi i’m just updated my unreal engine and was excited for the fact that android join session node is now working!

but when i went to package my project it said this error “Can’t make an APK without SDK API ‘android-28’ minimum installed”

so i checked my installed android sdk and yep, android-26 is the one i got installed

but when i want to install android-28 in the codeworks installer is says its gonna install android-26 again!

tmp.png
i dont want to redownload the android sdk for no reason, please someone tell me theres a fix for this without downloading anything :slight_smile:

i’ve found it, i do have to install android api 28 (android 9 api) but i have to install it through here

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“medium”,“data-tempid”:“temp_163208_1556470959503_160”}[/ATTACH]
https://forums.unrealengine.com/core/image/gif;base64

openning android.bat opens “android sdk manager” and through there i cann install android api 29

also i can install android api 1 in there aswell :cool:​​​​​​​

I ran into the same problem, but I found a strange workaround. I’m on an iMac running Mojave (10.14.5)

The Android SDK I use with Unreal 4.22.3 is the one installed by the Codeworks that comes with the engine. Standard install (no option). It doesn’t have android-28. It stops at android-26. So, I installed the SDK from the latest Android Studio and I moved the android-28 and android-29 files from its android/sdk/platforms folder to the NVPACK/android-sdk-macosx/platforms folder (where you had the android-19 to 26 files already.

It worked. It launches to my Oculus Go. I have to leave android-21 as the NDK API Level in the project settings though. Putting android-28 there generates the same error.

I figure this won’t hold forever. It is definitely not kosher.