Can't Login

When trying to login I get a “Please wait…” Message and it is stuck like that for ever, help would be appreciated.


I have this same problem. Mine is just stuck at login screen with “Please wait…”

This is driving me crazy.

Hi all,

I’ve assigned a member of our staff to look into this issue for you, and they’ll post here if they need any additional information. In meantime, please check our Launcher Troubleshooting Guide and see if any of that helps. If not, please follow instructions for getting your launcher logs and your dxdiag, and attach them in a reply here. Thank you!

I get same problem. And I contacted Epics billing/accounts dept who asked me to post query here instead. It appears to be a firewall issue. I can login just fine via a different network but not our more secure company network. This only started happening after Aug 5th update to launcher so something was added that our firewall doesn’t like. If Epic is able to disclose what ports/sites need white listing maybe this would help?

Hey everyone,

There was an issue with Launcher over weekend but it is fixed now. Try logging in again.

If it still doesn’t work, follow steps in this section of troubleshooting guide.

If issue still persist, follow instructions here to generate your Debug Logs. Then post them here, along with your Dxdiag (system specs).

Does this require a new version of launcher to be installed? If it doesn’t then I’m still getting sme problem. Somebody mentioned in a different thread that port 5222 needs opening?

No, this was a fix on our end so a Launcher update isn’t needed. You could try that fix but it is usually user specific.

Make sure to post your Debug Logs and Dxdiag here if it doesn’t work.

link text
link text

problem is still ocurring for me. Here are my logs.

my epicgames launcher still no working here its mylink text log and diag

Hi zmoke,

I don’t believe your problem is related to Y Yips, would be you able to create a separate answerhub post going into more detail about what you are experiencing exactly. Looking through log you provided it appears that Launcher ran and then it wanted to restart with debug logging enabled (which is done by adding -debuglogging to command line, which you can do manually). You could also try removing -http=wininet from command line to.



Hi Y Yip,

We’re currently investigating a number of “Please Wait” issues, some users have reported that right-clicking and running Launcher as admin fixes problem, if you want to give that a try in mean time.

If it still doesn’t work for you, then it may be a company IT issue, we’ll see if we can get a list of domains/ports that need to be open.


following domains/ports need to be accessible from Launcher port 5222



Okay we opened up port 5222 and it has solved our problem.

Hi everyone,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please try suggestion that abrown mentioned above. Then post back here with requested info.




I get this!
Is this normal?

Hope you can help me!