Download

Can't launch project on Android Device

Hi, I am new to developing games and apps for handheld devices. I need to develop an AR app for Android and thus I was testing out how a project runs on my android device, but as I am trying to launch it on my Android phone (OnePlus Nord CE 5G) it is handing out certain errors.

I have no clue how to get it running properly, please help me.

Hi Batu, iam not a professional but i made some apps so … i can only say what i would try :slight_smile:
First of all, it seems to have nothing to do with your Oneplus!
Has your project CPP Code oder is it Blueprint only?

  • Make a back up of your whole project and save it anywhere where you find it again
  • Then try do delete the folders i marked on the screenshot
  • Do not delete your “Build” Folder, when you wanna do this, backup your .keystore file (if you generate one)

Its possible that you lose your android project settings - this is no problem, just insert your data, Target SDK and Version Number of Android again :slight_smile:

grafik

Now start your project again and it will regenerate these folders again!
If you have luck, that’s all you have to do

Hi Sky,

Thanks for your input, I tried what you said but unfortunately it didn’t work, I am getting the same error. And I am using Blueprint for the project.

Also, the option “start in AR” is not available in project settings despite google ARCore and necessary plugins being installed.!

Screenshot 2021-09-12 213453|690x347
Screenshot 2021-09-12 213729