Download

Can't launch project anymore "Missing import: zlib.dll"

Hi,
I can’t run my project anymore. Im on 4.27 and am not getting any compile errors. But when trying to launch the project im getting the error shown in the screenshot below. The log show “LogWindows: Missing import: zlib.dll”

ue4

I have zlib.dll in this location:
C:\Program Files\Epic Games\UE_4.27\Engine\Binaries\ThirdParty\GoogleInstantPreview\x64\Release

But when checking the log and all the “Looked in” directories, it is not looking there

I have tried to delete all dll and rebuild.
I also tried to reinstall 4.27 engine.

Any ideas on how to procede?

Thanks.

Have you tried to start in from Visual Studio?
In some cases the wrong project is set up after the update. Then he tries to start the engine instead of your project.

Yes Im launching from visual studio

do you see the development editor and your project in the comboboxes at the top or the Ue4 entry?

If ue4 you have to set it up correctly like described in the VisualStudio Installation documentation from the ue4 documentation

to be more precise. I mean the startup project and the project configuration

Not sure what you meen, the project worked fine until master got merged with a new plugin. What I can see it is including zlib.h.

Looks like the problem is local to my machine as well