Cant launch/package new project(4.22) on Android: "No target name was specified on the command-line"


I haven’t previously done Android development in UE4, so I’m trying to set it up for the first time. I followed these guides:

Aside from that, since it didn’t work, I also put in the proper paths for the SDK, JDK, NDK, etc, here’s what it looks like. Also, here is what my platform settingsfor Android look like.

Anyhow, I’ve fiddled around, and searched for answers, but I haven’t found anything. I’ve also tried packaging to Windows64 and 32 with the Android configured project, same error (works with a new project which isn’t configured for Android though). To test that it wasn’t anything with my device, I tried building an APK from Unity on to my device, which worked without any issues. Here is the log text from the launch attempt.

I would really appreciate any help on the matter, thanks in advance!

Bump… There’s got to be someone who can help me? It can’t be impossible to build a game to my android phone lol without any help to get from any documentation or community.

For anyone curious, I “solved” the issue by downgrading to 4.21.2, and did the exact same thing, just worked …

This one is hitting me too. Anyone found anything?

Did your project is named “test”? If so, try to change the project name. I solved it this way.

This is the document how to migrate the project:


■■■■ test!