Cant launch on android devince on 4.25

i cant launch on android device and the log say in red:

“ERROR: cmd.exe failed with args /c “D:\Jeux enreal\Projet unreal\testandroiddevice\Intermediate\Android\armv7\gradle\rungradle.bat” :app:assembleDebug”


“java.lang.NoClassDefFoundError: Could not initialize class org.codehaus.groovy.vmplugin.v7.Java7”

hello, i found the jdk is in android studio folder at “jdr” folder et its working now but thnaks :slight_smile:

hi! i solved this problem by using this method!

in this page if you scroll down you can find the Java SE Development Kit 8u151

you’ll need to manual retarget the jdk in unreal project settings once installed.

Been Stuck on this too - and finally got mine working!
The answer is essentially the hooking up of the JDK folder needs fixing …

But I tried hooking up the actual JDK.2.1.21312 folder - with still no success
And it gave that error.

But after hooking up the the ANDROID STUDIO / JRE folder … mine worked.
(Not Android Sdk/Jre - but Android Studio / Jre)

Although mine is on MAC - so i had to point deeper - into Contents / Home as well
Not sure if on PC - just pointing to JRE might suffice (which i saw on some others tutorials)

But long story short - that error - represents - the hookup of the JDK - is still not good enough… and needs to be pointed ‘correctly’…

My settings above has (finally) worked for me.
Hope that helps some peeps!