Can't Launch Anything To Android - Help!

Hi guys,

I’m new to this, but I can’t get the Third Person Blueprint test project to launch on Android. Had a few issues with the build-tools which I solved by downloading and updating the SDK Manager, and now it seems to launch with no errors at least, but all I get on the phone is the Your Splash Screen Here screen. I’ve tried disabling it showing a splash screen at all, but then I just get a black screen. Few times log has stuck on Waiting for Server, but often it has gotten past that and still nothing appears on the phone.

Looking eventually to try get my completed project working on it (it’s a 4.10 and had some trouble with that so downloaded latest engine version to test) - but don’t stand much chance if even the example map won’t work!

Any help greatly appreciated :slight_smile:



Could you attach logs from launch session? Did you try to package project instead of Launch On? Does it work?

Thanks for the response! So, tried packaging it out the first time and it took what felt to be too long. Tried a second time and it worked! So thank you.

Also went back and tried Launch so I could grab the Log which is attached, along with my incomplete first Package. Is this just UE4 being unreliable? Anything I can do to make sure it works more consistently?

While I’m here - as I mentioned I have a 4.10 project that I ultimately want to get onto Android, specifically the Pixel 2 I’m using to test. Am I best trying to upgrade that project to 4.18 and then package it out? Is that even possible (pretty sure I did it with some really old projects when I first started learning, around 4.6)? Or am I better just trying to package it out on the engine version its on.

Thanks for your help!

You should totally update to 4.18