Can't integrate Wwise + UE4 on Mac

Could you try updating to Xcode 6.4? That’s what we were using to build the 4.9.x downloadable from the Launcher. The error looks like something older Clang doesn’t understand, but not seeing the whole compile output log it’s hard to tell for sure.

I’ve been trying to make Wwise 2015.1.2 and UE4.9.2 talk to each other on a Mac (Mavericks) and Xcode 6.2. I can’t update to Xcode 7 because I would need Yosemite or El Capitan. The integration doesn’t work. I always get the same errors when I start building in Xcode:

UnrealTypeTraits.h -/Volumes/RGR_AUDIO/Engine/UnrealEngine-4.9.2-release/Runtime/Core/Public/Templates/UnrealTypeTraits.h:204:17: Incomplete type ‘FInterpEdSelKey’ used in type trait expression


/Volumes/RGR_AUDIO/Engine/UnrealEngine-4.9.2-release/Runtime/Core/Public/Templates/UnrealTypeTraits.h:445:35: No type named ‘ConstPointerType’ in ‘TCallTraits’

This happens every single time even after following the instructions step by step. Is this a bug or a problem I can fix on my side?


I updated my OS and I installed Xcode 7.1 and this time I got a different error, although I’ve seen this one before. This is the error:

Command /Volumes/RGR_AUDIO/Engine/UnrealEngine-4.9.2-release/Engine/Build/BatchFiles/Mac/ failed with exit code 5

And the full log is in the picture attached.

Well it finally worked. I regenerated the Xcode project now that I installed Xcode 7 and it worked, Wwise is now integrated and fully functional but now in the UE4 Mac binaries folder I can only lunch the UE4Editor-Mac-Debug. Shouldn’t there be a UE4 Editor option?

I’m glad you got it working. You need to build the editor in Development configuration instead of Debug to have To do this, select Product->Build For->Profiling from Xcode’s menu bar or edit the UE4Editor scheme (Product->Schemes->Edit Scheme) to make it build Development config when you use Product->Build (this uses the configuration set for Run).

Yes! it finally worked! Thanks a lot

Hi there. A quick follow up - I had to uninstall UE4 and now I’ve rebuilt the engine and integrated Wwise again but I can’t generate Soundbanks in the demo project because of the following error:

LogAk: Starting Wwise SoundBank generation with the following command line:
LogAk: /bin/sh /Applications/ “/Users/Shared/UnrealEngine/UnrealEngine-4.9/WwiseDemoGame/UnrealWwiseDemo/UnrealDemo.wproj” -GenerateSoundBanks -Bank AmbientBank -Bank MatineeBank -Bank ReverbBank -Bank SwitchBank -Bank VelocityBank -ImportDefinitionFile “/Users/Shared/UnrealEngine/UnrealEngine-4.9/WwiseDemoGame/TempDefinitionFile.txt” -Platform Mac -SoundBankPath Mac “Z:/Users/Shared/UnrealEngine/UnrealEngine-4.9/WwiseDemoGame/Content/WwiseAudio/Mac” -Language English(US)
LogAk: cxmessage standin was called.
Fatal Error
‘cxbottle.conf’ is not readable. Check the permissions of the managed bottle files in ‘%s’
/Users/Rob/Library/Application Support/Wwise/Bottles/wwise
LogAk:Error: Wwise command-line failed with error 1.

Do you know what this means? I’d appreciate your help again. Thanks!

Sorry, but no, I don’t know what that means. One weird thing I see in the command line is this path: Z:/Users/Shared/UnrealEngine/UnrealEngine-4.9/WwiseDemoGame/Content/WwiseAudio/Mac. I don’t think it should start with Z: