Download

Can't install Unreal Engine

Hello,

I used to have a 2TB disk with Unreal Engine / Epic Games Launcher installed on it. Unfortunately this disk has broken and therefore has been dismounted from my system.

However, when I try to re-install Unreal Engine, the following error pops up: “Invalid Drive: G:”. As you may have noticed, G:\ is the disk that has been dismounted, but the installation is still registered to be on there. I’ve tried removing Epic Games Launcher through control panel, but won’t let me allow to do that either with the same error.

I have searched for broken registry values and also tried to repair my registry errors with CCleaner. This did not fix my problem, and I could not find any more references to a Unreal Engine installation in the registry. I have no idea what I should do to fix this issue and am out of possible fixes. Does anyone have advice or a solution to this problem? Or does anyone perhaps know some registry locations containing installed application information?

Help would be greatly appreciated!

EDIT: For readers looking for a fix: this problem was solved by a friend suggesting me to use Revo Uninstaller to permanently remove the installation from my system. After that I could install it again without any issues.

Sorry for the bump, but I use this for my studies.