Can't Install UE on Epic Games Launcher

When I try installing UE or anything else from Epic Games Launcher, a pop up appears saying “Product Activation Failed! An error occurred processing your request, please try again, Error Code: E10-0” How can I fix this so I can finally install Unreal Engine?

Re-Login into ur account and maybe making another account and downloading ue4 from that may help

tick as answer if it helps

I have tried signing out and back in a few times, still didn’t work, and then I made a new account and it still didn’t work. Please someone help me fix this!

Could the error be because I might not have enough space for UE4 on my computer? When I trouble shoot the launcher it says everything is all good including space wise but when I go to settings on my computer and check how much space is left, it says I have only 8 gigs left which Im thinking might not be enough space for UE4.

the launcher doesnt tell u if the space is enough or not i think just tells that there is space and the space is not too less also i think it tells if drive works fine. never used the troubleshooter so im not sure. but just my ue4.19 folder takes 20GB+

You Dont Have Enough space. 8gb is not enough 20GB+ is required. choose another drive.

Nevermind I fixed it, it was because I was using an internet that was blocking the launcher, once I started using a different internet, it started to install. And I ran as administrator.