Download

Cant Install EpicLauncher - Invalid drive? Cant change

Hey guys

When UE4 was released i downloaded it played around and gave up.

Over a year later i’ve come up with a story board, have an artist and a great idea for a Mobile game.

Back when i first installed UE4 i had an Western Digital 3TB drive, Which soon died and was removed. Its drive letter was Q:

The reason thats relevant is whenever ive tried to install UE4 in the past 3 days i get the error “Invalid drive path Q:”
-To troubleshoot this i went to my replacement drive “X:” and have run shrink on it for 30gb. Made another partition, Labeled it Q:

Reran the setup - It installed fine.

Logged into my account - Went to install UE4 engine SDK and realised the partition i had created was too small. Only 30gb. After assets and development id need atleast 100.

So i uninstalled - Removed the partition. Re-shrank the X: drive 130gb this time. Went to reinstall and i get this:

After clicking install [Note the empty drive path]

So what have i done to troubleshoot since.

Regedit. [used regscanner] looked for all unreal taged entries. Deleted them

Looked for all “EpicGameLauncher” tags. Removed all those entries.

Went to Uninstall Programs.

Uninstalled everything Unreal related.

Still the error remains.

Out of share frustration i booted into a Windows 7 USB and partitioned a drive to install clean Win7 onto it to install UE4 and use. However now that ive gone to Windows 10 - I cant use any of the drives that Windows 10 has associated to it. Without completely formatting them [Not an option! ]

So Back to windows 10 i go.

The error remains, Ive re-downloaded 3 times. It must be a registry error with the old installation,. But i cant find anymore entries relating to it anywhere. Nor can i find ANY files related to it.

as far as Regedit and explorer searches are concerned UE4 is no where on this PC. All i can assume is there are several key reg entries that arent tagged Unreal engine or Epic Games launcher that i cant find and havent removed - Hence causing this silly error.

Im so frustrated that i think ill give up for today and maybe tomorrow - I need a break! Been banging my head all day for solutions.

Can someone PLEASE give me some advice. I know Windows 10 isnt supported but im sure this issue is related to the fact i had installed this on release back when i was on Win7 and had that other now dead hard drive installed

If anyone can help - Oh god would that be amazing, Google hasnt been very useful.

Many people with similar issues but none that are identical and none of which solutions work in my case!

*bump! as i redid the original post

Double bump! Please help someone! I have tried everything i can find online. As i have 3 hard disks full of stuff i cant risk reformatting!

There must be a solution somewhere!

Make sure to post this on answerhub -> there someone from the epic support team will help you: https://answers.unrealengine.com/ :slight_smile:

Probably it helps when you uninstall the launcher with the Revo Unistaller Pro tool

Fixed - I posted on answerhub also!.

It refused to install regardless of revo and other uninstall cleaners.

I just manually extracted the .msi and dragged those files into a folder on my new drive.

Ran the launcher, downloaded unreal. All is well.

Thanks anyway :slight_smile:

@azkia23

Thanks for the tip, this worked for me.

I had all my Epic Games stuff installed on my F: drive, but that drive died a horrible death. Now, when I try to run the installer, or the uninstaller in control panel, it just pops up and says “Invalid Drive F:”

i got the same problem. tried to remove everything related to unreal. it wants a different HDD letter somehow.

Guys, I have found a solution for this problem.
So I downloaded this application called “Revo uninstaller” and selected Epic Games on the list. It deletes all the leftovers from the registries. After I finished deleting everything it let me install the launcher :slight_smile:
I hope it helps!

The drive you are trying to install the launcher on CHANGE THE DRIVE LETTER TO THE ONE INVALID. Ex. Drive C in computer “INVALID DRIVE (Z:)” Change drive letter C to Z then uninstall epic games launcher. after uninstalling epic CHANGE BACK DRIVE TO ORIGINAL LETTER. this worked for me I hope my instructions are clear im not really good at English

Hi, another solution I used to reinstall EGL:
note:The old registry entry will be replaced anyway, so you might as well just remove the registry key as said in the guide and reinstall.

  1. Use this guide to navigate to entry of the Epic Games Launcher in

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

- steps 1 to 3 - no need to delete the entry: Removing Invalid Entries in the Add/Remove Programs Tool

  1. (here you can just remove the whole key) Change the InstalLocation value’s data from invalid path to a valid path where you want to reinstall the launcher, confirm.
  2. Open the launcher and the path will already be pre-selected, if you edited the value that is. If you just removed the key, just set a path and install wherever.

I found it under this name, just hit cntrl+f and type in epic games launcher if you can’t find it, while highlighting
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall in the left panel, Thanks to Dave2S for the headsup. Just change the drive letter to a valid one in Installlocation, close it, then re-run the installer.