Can't install 4.10, insufficient space

Hello,

I searched this place and the forums briefly but I could not find any post about this issue.

Like many others I have a PC with a small SSD system disk (C:) and a secondary storage disk (D:). I have very little space available on C: so I run my UE4 projects from D:. The launcher is installed on D: and I can install engine versions 4.9 and older just fine, they install to the launcher install folder on D:. When I try to install 4.10.2 however there is a new little popup window that lets you check what you wish to include in the install. This popup window also calculates available space. For some reason it calculates space available on C:, which is insufficient for me to download and install. Is there a solution to this? 4.11 Preview has the same problem. I am using Windows 10.

You can build the engine from source. That will solve your issues! It’s not really too hard. I build my engine on a network drive on a RAID array actually. It works fine.

Download the files from github. (You will need to be granted access to the repository I think. It used to be this way. I’m not sure if it still is.)

I just download it as a zip from github.
https://docs.unrealengine.com/latest/INT/GettingStarted/DownloadingUnrealEngine/DownloadZip/index.html

Once you finish that step, then you need to build from source.

Also, if you are downloading 4.10 or newer, make sure you have Visual Studio 2015. The instructions haven’t been updated. 4.9 or older uses VS 2013.

Hi Dieselhead,

Sorry you’re having issues, it sounds like you’ve found an issue where the new installer is assuming it’s going to be installed to your C: when in reality it should be your D: Unfortunately the disk space checks are based of this (incorrect) location so it’s preventing you from installing unless more space is free’d up on C: (despite it then installing to D:). I’ll make sure a bug is entered to track this and get a fix out asap, thanks for bringing it to our attention…

Andrew

Thank you, perhaps this would be a good time to add the feature to let you choose engine install location :slight_smile:

It’s a bit of a hassle to do all this but it’s a good workaround for sure, thank you!

Your welcome!

I’ve entered an official feature request to have the ability to select what drive you install the engine on: JIRA [UE-26824]. If this is added to the engine, we will notify you with an update to this post.

https://github.com/EpicGames/UnrealEngine

Click on “Branch: Release” on the top left.

Click “Tags”

Click “4.10.4-release”

Click “Download Zip” on the top right

I would say 1 - 4 hours depending on your internet speed and CPU.

How can i download 4.10.4 version from Github !!
sorry i cant find the version !! plz help

Thank u so much :slight_smile: finally :smiley:
how much time req. to build engine 1 hour ! , How much space needed & How much to downlaod !! expect these source files ?
i have amd quad core 3Ghz…

ok thank u sir :slight_smile:
these commands still work- [TUTORIAL] How to use Setup.bat and how to reduce download size - C++ - Unreal Engine Forums

i want to work on win7x64 system
can i use this
“Setup.bat -exclude=WinRT -exclude=Linux -exclude=Linux32 -exclude=osx64 -exclude=IOS -exclude=HTML5”

ok :slight_smile: i will try that !!
thanks for quick reply :slight_smile:
Best regards…

Space? Uh, hmm, 2GB? maybe?

No problem :slight_smile: I think so. I haven’t tried them.