Can't include "windows.h"

I found other such posts here and here is MY info:
No special character in my profile name.
No change to my windows kit.
No change to my VS 2013.
Only change was upgrading to Unreal 4.7.3

I got this with a brand new project from third person template, added a class, this popped up.
Opened an older project, same error.
Reinstalled the kit, vs and unreal.

What do I do now?

1>------ Build started: Project: Islands, Configuration: Development_Editor x64 ------
1>  Parsing headers for IslandsEditor
1>  Reflection code generated for IslandsEditor
1>  Performing 10 actions (4 in parallel)
1>  [3/10] Resource Islands.rc
1>  [2/10] Resource ModuleVersionResource.rc.inl
1>  PCH.Islands.Islands.h.cpp
1>D:\Dropbox\Workspaces\unrealEngine4\islands\Islands\Source\Islands\Resources\Windows\Islands.rc(8): fatal error RC1015: cannot open include file 'windows.h'.
1>C:\Epic Games\4.7\Engine\Source\Runtime\Core\Resources\Windows\ModuleVersionResource.rc.inl(3): fatal error RC1015: cannot open include file 'windows.h'.
1>c:\epic games\4.7\engine\source\runtime\core\public\Windows/MinWindows.h(62): fatal error C1083: Cannot open include file: 'windows.h': No such file or directory
1>  -------- End Detailed Actions Stats -----------------------------------------------------------
1>ERROR : UBT error : Failed to produce item: D:\Dropbox\Workspaces\unrealEngine4\islands\Islands\Binaries\Win64\UE4Editor-Islands.dll
1>  Cumulative action seconds (4 processors): 0.00 building projects, 0.43 compiling, 0.00 creating app bundles, 0.00 generating debug info, 0.00 linking, 0.00 other
1>  UBT execution time: 8.72 seconds
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets(38,5): error MSB3073: The command ""C:\Epic Games\4.7\Engine\Build\BatchFiles\Build.bat" IslandsEditor Win64 Development "D:\Dropbox\Workspaces\unrealEngine4\islands\Islands\Islands.uproject" -rocket" exited with code -1.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

Try googling around this issue. My friend had similar issues. He fixed it by setting the environment variables for include path.

I gathered as much. Seems 8.1 is not what vs wants. It wants 7.0 but I need to point it to it. Couldn’t find the environment variables for the include path. This option is not there for unreal projects

It is inside the

Control Panel\System and Security\System

Advanced System Settings - Advanced - Environment Variables

But first can you look at the NMake’s Include search path?

I am using vs2015 btw.

Can I see your “”? Also you can try adding the absolute path to the file.

In visual studios if you search windows.h in the solution explorer, you’ll see it in the external dependencies folder. Click on the file and in the “properties” panel, usually on the right, you’ll see the path. For example my path is:

c:\Program Files (x86)\Windows Kits\8.1\Include\um\Windows.h

This is pretty hacky, and shouldn’t be necessary. For some reason your project isn’t include the necessary external dependencies. This is usually an issue of, you haven’t added all the needed modules. Post your *.build.cs so I can see if it’s correct.

I am using 2013 and my nmake looks very different. I manually included 8.1, 8.0 and 7.1 paths, still nothing. Why is a fresh project doing this? looks like a bug from unreal :expressionless:

I can only find Islands.Build.cs and it looks like thislink text

There is no “windows.h” in my external dependencies folder