Can't import Wav files under 1 second duration

Hi I think i found a bug.
When trying to import a very short .WAV file it did not want to import however when I extended that same file
to 1 second with Audacity it imported it just fine

Hello Para96,

Would you be able to provide me with the sound file you are reporting this issue with so I can test on my end as well?

Thank you,

Yes ofcourse,

I added the working version and the version that doesn’t work.
The working version was created by extending the time to 1 second.

For some reason i can’t add it as attachment so here is a link to the rar file with
both of the files.

Hello Para96,

Thank you for providing me with the requested information. After some brief investigating it appears this is definitely a bug as there is not definitive minimal accepted sound length allowed to be imported into the engine.

I have gone ahead and entered a bug report for this issue UE-16347 and we hope to have this issue fixed soon in the upcoming versions of the engine. We ask that you look in the release notes posted on our Forums for an update to this issue.

Thanks again for taking the time to report this issue and let me know if you have any further questions or need additional help.


Hi Para96,

The sound files you provided us are actually both the same length (0.237 seconds).

Here’s info about the working file:

File name	TerminalBeepExtendedWorking.wav
File size	0.05 MB (41,920 bytes)
File type	Wave (Microsoft)
Audio format	Uncompressed
Audio sample rate	44,100
Audio bit rate	1,411 Kbps
Audio bit depth	16 bit
Audio channels	2  (Stereo)
Audio length	00:00:00.237 (10,469 samples)

Here’s info about the not working file:

File name	TerminalBeepNotWorking.wav
File size	0.07 MB (66,284 bytes)
File type	Wave (Microsoft)
Audio format	Uncompressed
Audio sample rate	44,100
Audio bit rate	2,116 Kbps
Audio bit depth	24 bit
Audio channels	2  (Stereo)
Audio length	00:00:00.237 (10,469 samples)

The difference is that makes it work vs not work is the working sound file is 16-bit encoded and the not working file is 24-bit encoded. My guess is your export settings in audacity are set to export wav files at 16 bit.

If you look at your log output on the failed import, you should see the proper error message. Will look something like this:

“Currently, only 16 bit WAV files are supported (Name of your file here).”

In general that pop-up dialog that happens on failed import isn’t as informative as it could be. Always check the log output for more information.

A link to the issue on our public tracker can be found below.


Is there a minimal duration for sounds imported in the unreal engine? Is it normal that when I import footsteps sounds there is always a click or glitch of some sort? Every sound where normalized below -1dB and they all start and finish at zero crossing points. I’ve reimported the files in my daw just to make sure everything was OK. Is it a known problem?


hey Para listing i need your help in someting i have a problom that when i try to import a file it says cant create asstets and i got to this post i dowloaded your bip file and the one that you said worked worked for me and the one you said wont work didnt work now my file is is longer then 1 secend why its not working
and how did you extend the file ?

Hey 678GUY,

Please see the answer MinusKelvin provided and the link I attached for the issue on our public tracker for the official answer, and how to resolve the issue on your end.