Can't Import Any .FBX File

When I trying to import any .fbx file (even exported from UE or a simple box) FBX Import Options dialog freezes and editor not response. I have to end process from task manager. I tried everything that I found on this forum but non of them helped me. Do you know what is the problem ?


Can you provide your FBX file?

It wasn’t a specific fbx file. Btw reinstalling windows and UE solved the problem. But I wish to know what happened.

Next time you can try deleting the Config folder in the Project Folder > Config. We had an issue back in 4.6 where skeletal meshes could get stuck in a loop and not be reset properly because something was being set in that config file. That was fixed in 4.7, but there may have been another issue that allowed it to get stuck like this.

If you get the issue again, feel free to post and we can help you sort it out before going to the extreme of reinstalling windows and UE.

Also, if you created a new project we could see if it was just that particular project or if it was multiple projects that were causing the issue and narrow it down. More than likely it would be confined to a single project which would confirm the config file having something set improperly.

Either way, I’m glad everything is working for you now. I’ve assigned myself to this post so if you get the issue again feel free to post here and we can troubleshoot what’s going on. :slight_smile:

Thanks for your interests.I tried delete config folder. It wasn’t related just a particular project. I created new projects but all had same issue. I’ll update here if the issue occurs again.

That does seem odd then. Definitely let me know if this happens again. I’ve not seen anything like this outside of specific projects.

Thank you!

I am having the same problem. I found that I could use an OBJ file instead.
I always get a crash when I try to import FBX

reinstalling windows
Oh my…

This has started to happen to me as well,haven’t been able to figure out my problem im totally noob here but learning
Obj’s does seem to work but once i imported it didn’t have any skeleton bones it (the model) was lying flat…What gives with this seems the hardest parts of the software is getting the characters in how i want.Either they come im with color and i cant rig or they come in without colors and are able to be rigged o.O not getting it!

I am having this same issue. It started happening in the last few weeks. FBX files that I could previously import into Unreal Engine 4 are now causing the Unreal Editor to crash. I’ve exported OBJ files from Maya, but obviously this is not as clean or desirable. I’ve also changed the settings on the importer to not import the materials or textures on my FBX. This works, but again, not the desired result. Did something change that we are not aware of?