Can't hide mouse cursor when Setting input to UI


I need to set the input to be UI only, but when doing so, the mouse cursor automatically appears, and I’d like to not show it as it’s meant to be played with a pad.

My player controller has Show Cursor set to False.

Is there a bug or anything to know about this kind of setup ?


Hello Genova,

This is working as intended. However, could you try creating a custom cursor and then set the visibility of the widget used and let me know if this works for you? You can create a custom cursor by going to project settings > User Interface > Default cursor.

Hey Rudy,

Yeah that was my last resort, but that’s quite an annoying workaround. And the last time I tried, there was a glitch if you Alt-Tab : the windows cursor would be back along with the custom cursor.

On second thought, I can’t do that, I have some debug widget to manipulate my game. I need a mouse cursor ^^