Cant get touches to show in preview in Mobile version of my game

Can anyone tell me why I can see them in a blank template I just started for mobile but as soon as I import my Windows game map and assets then I dont see those touches in the mobile preview window?

Thank you :slight_smile:

I launced a new mobile template with starter content included.

I imported all my assets from my Windows version of the game and deleted the Pawn BP (character) that was in the template and imported mine in from Windows version.

Everything works fine. I did a build and everything works.

But Unreal seems to think that this is not a mobile game now so I am not sure how to tell it to show those touches in the mobile preview.

I did enable PIE in the editor preferences but that didn’t make any difference.

There is something that travelled with my assets from my Windows version that is making these touches not show.
I cant figure out what it is.
If I preview the physics ball template in a newly created project specifically for mobile then they do show up.
So not sure what the deal is here :slight_smile:

1 Like

I did force delete the character BP from the template maybe that is the issue?

So if I start a fresh mobile template and keep the original map and content in it just bring mine in then if I open the template starter map then the touches do show.

It still works.

But the moment I open my map (that came from the Windows version) then the touches dont show.

1 Like

Someone on Reddit suggested that my imported player’s game mode or controller might be overriding input settings which makes sense so I did a get player controller and activate touch imput and made sure the touch input is pointing at the virtual left joystick only.
Its still not working but I am doing a full build now and will restart the editor to see if that works.
I still don’t see any virtual joystick in the imported map with my Windows created player pawn BUT if I open the map with the default rolling pawn in it, it DOES show. So it is working with the default mobile template’s player pawn just not with the Windows created one.

Nope that didn’t work. So I guess its going to be a journey to get the virtual joystick to show in the preview.

I have a theory. I just launched a test new Windows project and when I look at the mobile preview the left virtual joystick does show. I think its because I changed the folder structure around in my project. I moved the pawn BP up one level and created my own Blueprints folder and moved the character BP in there. It might have “broken” the connection somehow and the preview doesn’t know where to find the virtual joystick or visa versa. That is what I think is going on. The virtual joystick does show in a newly created Desktop or console targeted template so it does work. So it can only be something I did as I started to build my own project in the template.

 Nope launced another Desktop targeted template, changed the folders around, fixed redirectors and I still see the virtual joystick.

So I dont know … Somewhere along the way I lost the virtual joystick in my project I guess I will never know when and how. :frowning:

I found a “set virtual joystick visibility” node and hooked that up with a get player controller but that doesn’t do anything either.

Another developer same problem:

Problem solved. Bad boy is found



wow, didn’t have my hopes up but you really figured it out :smiley:
an thank you cuz this helped me with the same problem!

Yeah I was sweating and drinking coffee there for a while :slight_smile:

I wondered about this topic.
A single person asked a question and he solved the problem on his own!