Download

Can't get the steam sdk version to change

Hi,
I’ve been trying to setup the Steam Online Subsystem, but I can’t get it to work. I followed a couple different guides, which all say different things. After using “launch” I finally got some output that tells me what the issue was. It says

LogPlayLevel: Warning: LogOnline: Warning: STEAM: Steam SDK 1.47 libraries not present at …/…/…/Engine/Binaries/ThirdParty/Steamworks/Steamv147/Win64/ or failed to load!

however I set it up with Steamv151. My Steamworks.build.cs file contains

  string SteamVersion = "v151";
    PublicDefinitions.Add("STEAM_SDK_VER=TEXT(\"1.51\")");
    PublicDefinitions.Add("STEAM_SDK_VER_PATH=TEXT(\"Steamv151\")");

I hard coded it in just to make sure, but it still doesn’t say the right steam version. I’ve tried everyway I could think of to rebuild and clean the projects to get it to take effect, but my logs still say its trying to access Steamv147. Am I missing something? Everything builds fine, but I have no idea if I’m building it correctly since my changes to this steamworks build file don’t affect the game.

I ended up just downloading the 1.47 version of the steamworks sdk and using that, and it works now