Download

Can't get spring arm to stop colliding with player!

Hello folks! Looking for a bit of help here. I have a character set up with a third person camera, everything works well except for the fact that when my character is moving (playing animations) the spring arm seems to collide with the player and causes the camera to jump forward. I believe it is the spring arm collision because if I disable “Do Collision Test” in its properties, the animations no longer make the camera move, however the camera will now clip through the floor and all other objects (as expected with no Collision Test)

I currently have tried to make my own camera trace channel, set to block, then in my character I have the collision on both the capsule and the mesh to ignore the new trace channel, however the spring arm still collides with the player. Here is my setup currently:

Capsule:

Mesh:

Spring Arm:

Collision Settings:

PS: I am on a laptop and can’t seem to use OBS to record UE4, so I can’t get a quality video to show my issue, but if needed I can record one with my phone.

Any help would be GREATLY appreciated as I feel like I have everything set up correctly, but that must not be the case… Also if I change the default response to ignore with the cam trace channel, there is no collision on the spring arm again.