Download

Can't get reference to actor.

Trying to make a sliding door , following this tutorial :
https://youtube.com/watch?v=JgDeHveVXII

But nope , doesn’t wanna get that reference to actor at 0.33.

Hello,
You need to select the actor in the level to have its reference.

Hey, I have tried that, doesn’t work.

If you : open the project / open your level blueprint / Click on an actor set in the level to select it / right click in level blueprint and you don’t see "create a reference of "the actor at top of your selection box and other related possibilities, you have an issue with your engine. Do a verify. If there is one thing you did not, this is that.

I created the bp from mesh in CB : right click > create bp using…

How can I get it to level bp ? What if I have want to have more BPs ?

The reference for an actor in a level in the selection box is for the level blueprint only not for every blueprint. You have access to level blueprint by clicking blueprints / open level blueprint at top of the editor. To create more blueprints, click on create in the content browser. And keep time to discover : https://docs.unrealengine.com/latest/INT/Engine/index.html

Edit : To set a blueprint in a level : drag it from content browser directly in level viewport.

The problem is that I am not seeing my door bluepring graph or components when I open the level bp.

Did you try this ? Did you follow the tutorial : It shows how select the actor in level, open level blueprint and add selected actor from level in level blueprint.

It works in the level blueprint… I need it in my door blueprint not in the level bp. I think so atleast …

As said here, you can’t have a reference directly like that in another blueprint. You have or to create a variable reference or get all actors.

Edit : Here is a link with infos : https://docs.unrealengine.com/latest/INT/Engine/Blueprints/UserGuide/BlueprintComms/index.html

Ok thanks.

Meanwhile I created a new one using pretty much the same bp for a rotating door.

Now I need my door to slide. I got it to work but the problem is that after I active the anim it resets to 0.0.0 location and also rescales to imported value.

How can I make this work properly?

db47897714.png

This is the rotating one which works just fine.

c22cec62121fb8f30a5a30ae73dcbd5f459b32e1.png

Am I using the wrong node or something?

I went ahead and created them in the level bp , had 6 sliding doors so I repeated the process 5 times.

HI, Have you checked “context sensitive” after right click in the graph ???

I had the same problem. That being, I was unable to reference an actor in my level BP. I know this dude asked this years ago, but the question could come up again for some one else and this page is still high on the google results page for “UE4 blueprint can’t reference actor”. My problem was that I am running multiple levels at once in the levels tab. I am trying to edit the BP for a level that is not the persistent level. I hid the persistent level and all other levels except the one I am working on. When I select an actor I cannot reference it in the blue print. Very frustrating. Here was my problem. Even though I hid the persistent level and am editing a different level, when I select level blueprint I am view the persistent levels BP. Inorder to edit the other level’s level BP you have to choose the option under edit level blueprint, which is edit sublevels. Once I opened the sublevel’s BP everything was fine. Just thought I would share in case it came up for some one else.

Thanks, Nofear169 for your recent comment. I believe I just encountered yet another way to experience confusion when trying to “create a reference to an actor”. I resolved my issue by reopening the level BP with the actor in question selected. I think the first time I opened the level BP, my desired actor was not selected. It seems like the level BP should allow you to create references to any actors within the level regardless of which actor is selected. Pretty basic functionality, it seems.