Download

Can't get Ray Tracing Translucency to work well with Exponential Height Fog

Hello,

Would really appreciate some help on this one if anyone knows.

See attached images

  • With translucency set to raster everything is fine
  • With translucency set to ray trace odd things are happening
  • Turning off Exponential Height Fog kinda fixes the issue in that the mesh no longer looks fragmented in the distance but there is still something off with the material.
  • Ground is megascans materials straight from bridge - It does seem to act strange with RT translucency on (not sure why a rock mat would need translucency)

In general turning on Ray Tracing Translucency seem to mess with things in an unwanted way. I actually only want it for some windows on a car else where in the scene because it looks so much better, rocky ground is just far away background filler. Alternatively is there a way to only apply the RT translucency where I need it?

Many thanks,

Did you try to make a PostProcessVolume only bound to your car windows?!?

Hey,

Yea this was my first idea I had, to make a second small post process box around the car with RT translucency on. It doesn’t work though because to my knowledge you have to be inside the post process volume to see it’s affects. So once inside you see the affects of RT translucency on everything in the distance too so it doesn’t work unfortunately.

Is there a technique I’m missing here where this is actually possible? would be great if so.

Thanks

Unfortunately I can’t help.

It is possible. In this scene I pumped up the fog density from .01 to .1 so you can see the fog. I’m using the ultra dynamic sky here (from the marketplace). You can see the settings on the left. It might use a fog component in the blueprint but the settings should be very similar to the fog actor.

It might not have all the features and not look super realistic yet but there is definitely fog in the scene. Hope that helps.

If this is just a static background scene you may also get away with a large fog plane. Just a giant plane with a translucent fog like material on it placed in the background.

Did you manage to solve this problem somehow, because it also doesn’t work in ue5?

i am pretty sure that its either a bug or a known issue listed in the documentation. some things just don’t work (well) together.
i suggest using rasterized translucency in the mean time