Can't get Quixel to work inside my project says offline or needs update

…but there is no obvious way to update it.

Oh well I guess i’ll just download the files zipped and add them to the game that way. Tedious but no one seems to know how to fix this.

1 Like

Solution 1:

  1. Close Unreal Engine, if already running. (You can not update the plugin if the Engine is running in the background)
  2. Run Epic Games Launcher , go to the Unreal Engine Library, and click on "Installed Plugins " under UE5 Early Access.
  3. This will open up a new window and you’ll get the option to update the plugin.
  4. Once updated, launch Unreal Engine 5 Early Access. Now you’ll have the updated plugin incorporated!

If the issue persists, try the following steps:

  1. Navigate to Engine/Plugins/Bridge.
  2. Download and replace the files shared here.
1 Like

Hi @DracFayVamp,
There is a fix update to Quixel Bridge 21.0.4 I wrote about it in a thread
Quixel Bridge 21.0.4 Update to Unreal 5.0 EA2 Epic Launcher Binary version - Unreal Engine 5 Early Access

I hv fixed this issue by switching off Windows Update from My PC - Manage - Services - Windows Update - and set startup type to Manual or automatic . Restart Unreal engine 5 and open Quixel Bride - Login issue will be solved.

guys from support help to root the problem - it was Eset NOD32. Here is the steps to fix it. I did it and all worked.

We were able to root out the issue to the ESET NOD32 Anti-Virus. After it’s most recent update, it seems to be blocking the Bridge Plugin within UE5 from communicating with our servers.

We have sourced the following workarounds for you to try:

1) Uninstall the Anti-Virus entirely. (This ensures that the issue will not come up again)

2) Follow the steps below:

  • Navigate into Setup > Advanced Setup > Detection Engine.
  • Select Network Traffic Scanner and Disable it.
  • You should now be able to run Bridge within UE5 successfully.

Heh I here to write the same. I wrote them and the problem was NOD 32. I done second option and it worked!