Download

Can't get new builds (5.0, 5.1) to run on Linux

I am having trouble getting a working build from the 5.0 branch on Linux.

I can compile it successfully; but when I launch the editor it crashes before it even gets to the project selection. Its difficult to tell exactly what the cause is; but it appears to be happening in “libUnrealEditor-TextureFormatOodle.so”.

I have also tried the ue5-main branch (which is at 5.1) but it fails in the same way as the 5.0 branch.

I am able to to build and run UnrealEditor from the ue5-early-access branch, and looking at the logs, it doesn’t appear to do anything with Oodle in that version. That may be an indicator of why one is working and the other is not; or it could be a red herring.

Has anyone managed to get UE5 built on the 5.0 branch (recently) in Linux? If so, did you do anything special?

I am building from the 5.0 branch at the latest commit (70b5e4801c8a3c1740794490d030808a7f6082b8) and from the ue5-main branch at the latest commit (b516c7819c4404aca2a68bcbfd15e4dd4e6c1489)

As of this morning, I was successfully able to run the 5.0 branch on Linux.

I am not sure which commit solved the issues; but the latest commit (in case it breaks again) I tested with is 92a910054adf0581263e840c4bd1ff116130cbad