Cant get NEF raw files to work coming from nikon D3400

I just downloaded the lasts RC version. I cant get latest version of reality capture to align raw NEF files from Nikon D3400?

I keep on getting invalid or corrupted input data error?  I’ve tested it on two computers and still get the same error.  I tested it with a jpeg sequence and it worked fine as well as with the sample datasets.


Please make sure to only import images. Sometimes people accidently select other files aswell with the images and get such errors. If none of this happened try to reinstall .NEF codec for your Windows. 

Erik, i have double checked my attempts and we are seeing the same thing with Nikon D850 .NEF images in case of error without change. We have reinstalled the codec but have not been able to resolve this issue.

Dear Luke,

are you able to open these .NEF files in any other application on your computer?

Hi Erik,

Yes i am, I am able to open them in windows (standard viewer) and can zoom in. I was able to process the images through capture one into jpg but am trying to avoid this where i can. I was able to process the same image set without issue in the last release.

I had NEF Codec Version 1.31.0 installed and also rolled back to Version 1.28.0 to try that but it did not help.

The above image is what gets shown if you click “convert” on import or HDR image. if i click original, it closes the dialog box but then if i click “align” it gives the same issue. error code [0x10003\0x10001\0x4999\0x10001]

Then please contact us at

Shortly describe the issue, upload some of the images somewhere and put the link in the email. 

We will take a closer look and will try to fix your issue asap.