Download

Can't get menu widget to focus without clicking twice

I have a pop-up menu widget which appears right after the level loads and play begins. For reasons I can’t figure out, the player has to click twice to select an option: The first time to get the widget to focus and the second time to actually select an option. The blueprint calls SetInputModeUIOnly and specifies the target widget as the one to focus. But the focus does not take effect without having to click on the widget first. Why is this not working?

I have had this issue as well with my menu, but only on my ingame Quit/Continue Menu…
All other menus work fine, except that one… which has the exact same problem, you have to click to focus it, then the buttons will highlight and function as they should.
Would be interested to know why as well! I’ll have to revisit the menu anyway when I rebuild it for 4.10, so if I come up with a solution, I will let you know :slight_smile:

Check to see if you have a controller assigned for the input mode change and show mouse cursor if you have it. I also remember having that issue if I was showing/hiding multiple widgets before trying to set focus for input.

I assigned the controller when I changed the input mode to UI only. I also specified the widget to receive focus. Doesn’t seem to do anything. The input mode is correct. But you still have to click on the window to get it to respond to the mouse and keyboard.

That was it! Thank you so much! I was so overwhelmed when going in to start fixing this issue but with your help it only took a few seconds. In the case that anybody else had problems, configure it like this: https://gfycat.com/PhysicalSecretKob

Worked Perfect, Thank you g**uys! Below is a screenshot also of my setup in case someone else runs into this. **

Hey guys,
Just dropped by to say thanks.
Years later this simple solution is just what I needed
(sorry if it brings this thread to the top)

Same here. Just came to say thanks because it has solved my issue.