Can't get Epic Games launcher to install

After subscribing I tried to download for Mac OS X, but the Epic game launcher keeps giving me an error: Updating Epic games launcher Error! Install failed. Please help!,

Hi Jakebob38,

Please try the troubleshooting steps in the “Unable to Install the Launcher” section of the link below. Afterwards, let us know if anything worked.

Hi Jakebob38,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, try the troubleshooting steps linked above. Afterwards if the issue is still present, post back here to let us know.



Hi , try this :

    Right-click your launcher shortcut and choose properties.
    At the end of the target path field add “ -http=wininet” without the quotes and make sure there is a space before the dash. It should look like this:

I’m having the same issue with installation, but I can’t even get the launcher installed and I have windows 10. I have downloaded the installer from the website the installer version is 2.11.9-2970807, I have DirectX 12, My OS, video card/everything else are up to date, I have tried all the trouble shooting steps listed EVERYWHERE I can find, with no results. I have opened a ticket, but it’s been slow in response to say the least. ANY help would be great… that is if anyone has any. I have included an image of the error and the DX Diag. if it may help.alt text

Psst dont revive dead Posts (look at the date) :stuck_out_tongue_winking_eye: also the step you mentioned is also in the troubleshooting link provided above

The Irony being that I followed the link and tried all the steps and it still didn’t work. along with the recommendations and “solutions” listed on about 7-8 OTHER sites for the same issue and still nothing worked… It’s ok tho I have a friend that does coding and he modified the installer so that it no longer tries to force DirectX if there is a newer version already installed. Best of luck