Download

Can't get Devkit to work at all.

I have the devkit installed, updated etc. I was told it’s now all in the unreal engine download so idk if I’m missing something or what…

I open the file, watched the basic tutorial video on how to make a mod and went to do it… Right clicking anything freezes the client totally… I have to ctrl alt dlt out everytime. I can create a new file, but copying the PrimalGameData_BP_Generic file into the new mod file freezes it, even click/drag does it… I can modify the default files to my heart’s content but I don’t want that, I want to make something entirely different etc the whole purpose of the kit… so I’m curious as to what to do from here… is my computer not good enough? Being a 1300 USD computer… Even though I see people with much worse computers do much more with them lol… am I missing something? Do I still have to go to all the different websites installing this and that to get it to work? I’m confused : (

All help is very appreciated!

Side Note: It was working back in September when I first installed it… creating mods/files/etc everything worked. Now it just doesn’t

The ADK can be — well… VERY SLOW. Like 10-15 minute, looks like it’s frozen, slow.

Every time I run it, I open my starting map - go make a sandwich, get a drink, recreate the Mona Lisa, etc.

The first thing always makes it cough up a lung for me, but after that and maybe an item or two later, it’s smooth sailing. In fact, I just don’t shut it down anymore.

The way I know it’s still doing something: in the Task Manager it says: not responding - but the CPU is still fluxing around and the memory being used steadily rises.

As pointed out, but I’ll explain a little further.

The DevKit needs to load into memory all of the references associated with a given file, it doesn’t do this when you open the DevKit, it will only do so when you interact with a file. PrimalGameData will be the biggest performance hit and take the longest(other than when loading maps/levels) as that file references every file in the game through itself, files it directly references, and through files those files reference… and this continues until it has essentially loading the basics of every file - this allows files to be opened in a second or two after you do this the first time each time the dev kit opens.

One other thing that also happens is the DevKit needs to compile shaders so the meshes, textures and all of that jazz can be viewed in real-time.

Keep in mind though, this only happens the first time you attempt to open a file in the Devkit after you launch it. It’s good practice to open the dev kit, click on a primalgamedata, move your mouse away from it(otherwise it will freeze the pop-up on your screen for the duration of the loading) and hit enter, then let it do its thing.

How long it takes to complete will depend on a few things, the speed of your harddrive or storage you’re using(it needs to read files and this is the biggest performance factor with the devkit) and the capabilities of your CPU and RAM but to a lesser degree.

It should be noted that at least 4GB’s of ram is needed for the DevKit, as a general rule - as the devkit will grow to about 1.5-2.5-ish GB’s when loading primalgamedata’s, and somewhere in the range of 8-12GB’s is needed if you attempt to load the Island levels/map into the DevKit.

-WM