Can't generate Xcode project files on Mac

I am trying to build Unreal Tournament and I am stuck at Generating Xcode project files, I am getting this error :

Errors detected while compiling /Users/user/Documents/UnrealTournament/Intermediate/Build/BuildRules/RocketUE4ModuleRules.dll: 
/Users/user/Documents/UnrealTournament/Source/BlueprintContext/BlueprintContext.Build.cs(65,3) : error CS0103: The name `MinSourceFilesForUnityBuildOverride' does not exist in the current context 

/Users/user/Documents/UnrealTournament/Source/BlueprintContextEditor/BlueprintContextEditor.Build.cs(37,3) : error CS0103: The name `MinSourceFilesForUnityBuildOverride' does not exist in the current context 
UnrealBuildTool Exception: ERROR: UnrealBuildTool encountered an error while compiling source files

I am using since I didn’t compile the engine myself, I have Unity3d installed in the same machine and Mono came with it, not sure if this have any relation with this error

Hi mkhaled,

Can you post your dxdiag here so I can take a look?

Are you downloading the UT Editor or UT Game?

What are the steps you are taking before this error occurs?

Have you tried verifying your build?

Hi , Thanks for replying
I am not sure about dxdiag on Mac, as far as I know this is for Windows, is there one for Mac too ? sorry if this is a stupid question.
I downloaded UT Game from github from this link
just unzipped the file and tried to generate xcode project files by : right click on “UnrealTournament.uproject” file → services → Generate Xcode Project Files.
and for the last question, how can I verify the build ?

Definitely want to be using GenerateProjectFiles.command and not RocketGenerateProjectFiles. I have not actually tested building the github build on mac. Also would not use the right click menu, when I do local builds I just run ./GenerateProjectFiles.command from a terminal.

The Mac information can be found in the Apple Menu>About this Mac>More Info. I specifically need the RAM, processor, and video card/driver information. Additionally, please try the solution knepleyp suggested below and let me know if that works for you. The verify option is for the binary launcher version of UT as opposed to the github build.

right click the computer stucked.