Can't generate Visual Studio project files

Hello everyone,
I am working on a project in Unreal Engine and need to regenerate the VS files. Whenever I try and right click on the uproject file to do this, however, the option to generate is not there. I have tried associating the uproject file with UnrealVesionSelector to fix this (as many say to do) but when I go to Unreal Engine/Binaires/Win64/ it is not there. I have even tried manually copying the file from the Epic Games directory to the desired location in the Unreal engine directory (as described in this video Unreal Engine 4 Project File Re-association - YouTube) and although it does change the uproject file to have a blue unreal icon, the option to generate is still not there.

I understand that there are many questions on this issue in the forums already but none of the suggested solutions have worked for me. I have spent a lot of time searching the web for answers, and a lot of brain power thinking about possible solutions. Any help you might have would be very much appreciated!!