Can't generate a signing certificate for Hololens 2

I have followed the instructions to package a project for HoloLens 2 here:

Packaging An App for the Hololens 2

When I get to the instruction:

Go to Project Settings > Platforms > HoloLens > Packaging > Signing Certificate and select Generate new

I get an error message:

“Failed to generate certificate: could
not locate makecert.exe”

I have completely reinstalled UE 4.25 from scratch but still have the same error.

I have tried to search the engine install location for “makecert.exe”. There is a file called MakeCert.exe at this location:

C:\Program Files\Epic Games\UE_4.25\Engine\Binaries\ThirdParty\Mono\Mac\lib\mono\4.5

This doesn’t seem relevant though; it looks like it could be for Mac development?

Does anybody else have this issue or know what could be causing it? Many thanks.

I tracked the problem down to the Windows 10 SDK. When I had installed this to Visual Studio it must not have installed properly. I uninstalled and reinstalled the Windows 10 SDK and all works fine now.

Not Working is there any other solution for this

Find the Solution Just make Sure to Download Window SDK10.0.22621 This SDK is for Window 11 and i have Window 10 but still but still its working for window 10. just install it and generate your Sign Certificate in your Hololens Project.

no work