Can't find file for non-existent asset

Hi

I am trying to package a project for Mac and get the following log Warning:

LogLinker:Warning: Can't find file '/Game/Architecture/SM_Floor_400x400'
LogLinker:Warning: Can't find file '/Game/Architecture/SM_Floor_400x400'
LogUObjectGlobals:Warning: Failed to find object 'Object /Game/Architecture/SM_Floor_400x400.SM_Floor_400x400'

This is an asset that I think was in an earlier iteration of my project but is no longer anywhere in the existing version and is nowhere in the Content.

Can anyone explain why this reference persists and how to remove it?

Thanks!

This could be happening because of an invisible “object redirector” that is sometimes created when an asset is moved or deleted.

To get rid of these open up the Content Browser, then right click on the Content folder and choose “fix up redirectors”.

Doing this permanently applies the changes to any asset that references a redirector by either pointing directly to the asset, or removing it if it no longer exists. You may still get an error if one of you assets was referencing a deleted asset, but it should tell you which asset needs to be fixed manually.

Hope that helps!

DC

This should work… Also be sure not to have a period in any of your asset names (ie “SM_Floor_400x400.SM_Floor_400x400” should be:

SM_Floor_400x400_SM_Floor_400x400’”

It does have the appearance of a possible issue with asset names but the original name was simply:

SM_Floor_400x400

The log file has appended the period and repeat name.

Hi please help me I have the same problem. When packaging the engine tries to load inexistent files
For example:
“UATHelper: Packaging (Windows (64-bit)): Cook: LogUObjectGlobals: Warning: Failed to load ‘/Game/ArchVis/Materials/M_Ceramic_Mat_Inst’: Can’t find file ‘/Game/ArchVis/Materials/M_Ceramic_Mat_Inst’”

Could you please help?

Did you resolve the problem? I’m getting same error even in 4.25.3! The engine is trying to find a footstep sound asset that I never have added to the project!