"Can't find file for asset. /Script/CableComponent" on 4.12

After upgrading my project from 4.10 to 4.12, everytime I open it I get the error
“Can’t find file for asset. /Script/CableComponent”

It works if I just go to my hookshot blueprint, readd the Cable Component and redo it’s conections but it’s a pain to do that everytime I reopen my project.

Tried adding CableComponent to the dependency modules on my Build.cs and the I’m still getting the same error. Any ideas?

Thanks.

Hey,

Sometimes when you upgrade your project the blueprints gets “dirty”, I think this might be your problem.
Try the “Fix up redirectors” by rightclicking in your content browser.

There are also some other ways to force Unreal to clean it but this one is the easiest.

Hope this helps :slight_smile:
Elias

Thanks but I’ve tried it and I’m still getting the same error. :confused:

If you duplicate the hookshot BP, does it also give this error?

Well, if I duplicate it, the new object comes with the same error. I even tried recreating the hookshot BP from scratch and I still get the same error when I close and reopen Unreal.

Fixed it.

If anyone is having a similar problem, I had to open “C:\Program Files\Epic Games\4.12\Engine\Plugins\Runtime\CableComponent\CableComponent.uplugin” and change the LoadingPhase from “Default” to “PreDefault”

I believe that makes the plugin load up earlier.

1 Like

Just want to say thanks for figuring this out! This was driving me crazy yesterday. This fix works fine in the latest version of the editor too.

This is still an issue in 4.14(.3) – it’d be great if Epic could have this fixed off the bat so we don’t have to tweak built in components.

(In my case, I had a blueprint inheriting from CableActor that was becoming invalid every time I loaded. I’d create a new blueprint to replace it and whenever I next loaded, just found that this new one was broken now [but the first was fine].)

Thanks a lot!

thanks!! worked for me too

This worked for me for the unreal wiki AI Utility plugin and 4.22.

I had some problem with Niagara.
Have error: Can’t find file ‘/Script/NiagaraEditor’.

Changed all boot options from Default to PreDefault. The problem is resolved.
Thx.

Can you expand on that further @DenKuzn? I have the same Can’t find file ‘/Script/NiagaraEditor’ error. What boot options did you exactly change? I have tried to fix this issue for the last two hours and it’s driving me crazy…

EDIT: I found it… Since Niagara didn’t successfully load i edited the uplugin file for Niagara located in C:\Program Files\Epic Games\UE_4.22\Engine\Plugins\FX\Niagara

This did indeed fix my issue. I’m leaving this here for future readers