Can't find "Cast to bp_itemMaster"


I’m unable to find a cast node in the blueprint editor. I need this node for making a inventory system in my project (i’m a beginner), but it’s not visible. Someone solved this problem recompiling the node, but i’m not sure how it works…

Thanks in advance

Instead of dragging wire, just right click and search for “cast to bp_itemMaster”

I tried, but unfortunately don’t works…

Do you know how can I recompile “Cast to bp_itemMaster” ?

If unchecking ‘context sensitive’ doesnt work, the next question to ask is what class are you in? (It says at the top right corner in a grey link, ie. actor, character, pawn etc.

Some classes wont allow casting to a class like that.

Next we ask. Do you even have a blueprint called bp_itemMaster? Click on your content folder and search for bp_itemMaster if its not there, you need to create it, thats not a stock blueprint you need to create it, you may have called it something else.

What tutroail are you following? It looks strangely familiar to my BP Inventory/Crafting/Placeable Structures tutorials.

Hope this helps
Don’t forget to accept an answer that best clears your question up or answers it so when the community finds your question in the future via search/google they know exactly what you did to fix it/get it going.

Oh thats funny. I just posted an answer. It is my tutorial… let me get back to you. I’f you’d like add me on skype BlenderTek I do live support.

Try unchecking “Context sensitive” on top right corner.

Done, but it’s the same situation. Can’t find the node

I watched this video :

On minute 7:24 that guy had the same problem. He solved by recompiling, but i don’t know how to do it

All that happened there was my computer crashed. I lost some work. Make sure your BP_itemMaster has the struct variable in it, and set to editable, and make sure its of the actor class. And then compile and save.

Now in your character class when dragging off of actorTraced, compile and save first, then try dragging off. It has to be there.

I can upload the project for you if I still have it if you really cant get it.

Thank you for your time, Recompiled and now it works properly.