Can't filter or sample regions using 'Mesh Reproduction Sprites'

I’m trying to limit where sprites are rendered over a skinned model using the mesh reproduction sprite Niagara function. There’s a couple of options but they don’t seem to do anything (see screenshot):

A) Sampling regions: (‘Sampling regions from the mesh from which to sample’): I set up a region in the mesh and referenced it from the option as illustrated in the screenshot. Nothing happens.

B) Filtered bones: (‘Set of filtered bones that can be used to sample’): Selected a bone (i.e. head), and still, the sprites keep on showing over the full mesh…

Puzzled here. Don’t know how to use this feature…

336930-screenshot-sk2.png

!

Un-check apply to children

From UDN in case anyone else bumps in to this:

‘Niagara only supports sampling regions that are triangle based, rather than bone based. You’ll have to use the bone filter list for this, but the Mesh Reproduction Sprites module samples triangles, not bones, so this won’t have an effect. You can use the Skeletal Mesh Location module to sample bones, then set the Bone Sampling Mode to one of the filtered options.’

→ So basically if I want to limit from where the particles are being created it has to be through a material or a material id, correct?

‘For surface (triangle) sampling, yes. If you are sampling bones, you’ll need to use the Filtered Bones list.’